Troubleshooting
Problem
When trying to connect with one of the InfoSphere DataStage clients you receive the error: Failed to connect to host, Internal error 39202
Symptom
When trying to connect with one of the InfoSphere DataStage clients you receive the error:
Failed to connect to host, Internal error 39202
Cause
In order to troubleshoot what part of the connection to the project is failing, it is best to turn on Server Side Tracing for the failing project. Server Side Tracing you should where the connection code is failing.
- Server side tracing can be turned on in 2 places, from the InfoSphere DataStage Administrator and from an DataStage engine prompt.
- If you can open the DataStage administrator:
Click on the Projects Tab, Click on the project with the problem and click on Properties.
Click the Tracing tab and Check Enable - If you can't open the Administrator client, you will need to turn on tracing at the DataStage engine level.
- Telnet to the DataStage server machine and login as your DataStage admin user
cd to the DSEngine directory
Unix/Linux:
Source the dsenv by typing:
. ./dsenv
Go into the engine by typing:
bin/uvsh
Windows:
Go into the engine by typing:
bin\uvsh - At the ">" prompt type:
LOGTO projectname
Where project name is the name of the project with the connection issue.
Once in the project type:
RESIZE &COMO& 19
TRACE ON - Now that tracing is turned on, attempt to open the Designer Client. You should get a warning message that server side tracing has been turned on.
- Login so that you receive your error message
- Once you get the error, turn tracing off.
From the Administrator, uncheck "Enable".
From the Engine prompt type:
TRACE OFF
When it asks if you want to clear the trace files say No. - You can view the trace files in the administrator on the same screen where you turned tracing on.
- If you cannot get into the Administrator, you can cd into the &COMO& directory in the project and see the trace files in there. The trace files/directories begin with DSRTrace and are all ASCII files
- Review the log files to find the full error messages corresponding to the connection issue.
[{"Product":{"code":"SSVSEF","label":"IBM InfoSphere DataStage"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"},{"code":"PF027","label":"Solaris"},{"code":"PF016","label":"Linux"},{"code":"PF010","label":"HP-UX"},{"code":"PF002","label":"AIX"}],"Version":"8.1;8.0.1;7.5.3;7.5.2;7.5.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21431890