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SQL10007N Message "1390" with RC= 3 performing administrative actions in Control Center

Troubleshooting


Problem

When performing administrative actions in Control Center, such as Configuring Automatic Maintenance, the below error is received: SQL10007N Message "1390" could not be retrieved. Reason code: "3".

Cause

The node that is associated with the database you are trying to right click on and choose "Configure Automatic Maintenance", was not cataloged with the "remote_instance" keyword.

Resolving The Problem

The problem is in the catalog entry on the client, where the TCP/IP node of the Linux, Unix, or Windows database server is defined. Many Control Center functions, such as Configure Automatic Maintenance, HADR, License Center, and Design Advisor, need to know the remote instance name of the database they are connecting to in order to work properly. Re-cataloging the TCP/IP node with the "remote_instance" and "OS TYPE" parameters should resolve the error.

See the Related URL section below for information on how to catalog a remote node. Before re-cataloging the remote node, you will first have to uncatalog the remote node by running "db2 uncatalog node nodename" (where nodename is the name of the node you currently have cataloged) from a DB2 command window.

[{"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"DBAdmin - Control Center","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.7;9.5;9.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 June 2018

UID

swg21431573