IBM Support

WDI 3.3 SFP filesets on AIX show installed with an Inconsistent State

Troubleshooting


Problem

A problem was discovered when installing WDI 3.3 Server Fix Packs on AIX system. After applying WDI 3.3 SFP1, SFP2, SFP3 or SFP4 "lslpp -L IBMWDISERVER33" shows the state as "INCONSISTENT" / "EFIX LOCKED" as denoted by the symbols "?E" in the state column.

Symptom

This problem does not pose any threat to the operation of WDI 3.3. However if you want to uninstall the WDI Server product, then the uninstall might not complete, leaving the WDI 3.3 ODM entries present. This will not allow the WDI base product to be installed again until these entries are removed.


Issuing the command "lppchk -v" indicates the following WDI 3.3 filesets in the inconsistent state.

Cause

An issue was found with AIX install shield when installing WDI 3.3 Fix Packs. The problem is not present when installing the WDI 3.3 Server base product.

Environment

WDI 3.3 on AIX

Resolving The Problem

No action needs to be taken at this time unless you wish to remove WDI 3.3 Server and reinstall.


Follow the below steps to remove WDI 3.3 Server on AIX after a WDI 3.3 Server Fix Pack has been installed:

  1. Run the uninstall script for WDI 3.3:
    For example: "./opt/IBM/WDIServer/V3.3/uninstall/WDIServerUninstall.bin"
  2. After uninstall completes, you may receive a failure message that the product was not uninstalled successfully.
  3. Remove any left over files and folders from the /opt/IBM/WDIServer/V3.3 path
    For example: "rm -R /V3.3"
  4. Run "lslpp -L IBMWDI33SERVER" and "lppchk -v". Make a note of the output results.
  5. Download the following file in binary to the /tmp folder. Next untar the file and change the permission's to allow for execution of the script. You will need to run this script as root user.
    manual_WDI33SFP_ODM_wipe.tar

    You will need to run this script as root user.
    For example: "./manual_WDI33SFP_ODM_wipe.sh"
  6. The following txt files will be generated by the above script. Please keep those files temporarily, as IBM support may need them for troubleshooting purposes if the ODM entries are not removed after running the script:
    clean.hst.all.txt
    clean.inv.files.txt
    clean.lpp.lppid.txt
    clean.lpp.name.txt
    clean.prd.name.txt
  7. Next run the command:
    For example: "lslpp -L IBMWDI33SERVER" and then "lppchk -v".

IBMWDI33SERVER should not show to be installed any longer for the lslpp command and lppchk -v should no longer show any WDI 3.3 filesets installed or in the inconsistent state.

NOTE: IBM Support has resolved this problem in SFP5. By applying WDI v3.3 Server Fixpack5, the steps listed above are no longer needed, unless you have already attempted to install one of the previous Server Fixpacks listed.

[{"Product":{"code":"SSFKTZ","label":"WebSphere Data Interchange"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"WDI 3.3 MP","Platform":[{"code":"PF002","label":"AIX"}],"Version":"3.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21430165