IBM Support

OnBar imported restore, restore or OnBar -v returned XBSA error 96 (0x60)

Troubleshooting


Problem

When you try to do an imported restore using OnBar, you get error 96. Using OnBar -v to verify the backup also return 96.

Symptom

Example of error message from running OnBar -v command in bar_act.log:

2010-03-25 11:29:06 24644 24642 /opt/informix-11.50.fc4/bin/onbar_d -v
2010-03-25 11:29:06 24644 24642 Successfully connected to Storage
Manager.
2010-03-25 11:29:06 24644 24642 XBSA Error (BSAGetObject): An
unspecified XBSA error has occured: 96
2010-03-25 11:29:06 24644 24642 Object information: bar_objdesc
2010-03-25 11:29:06 24644 24642 (-43342) Cannot read reserved pages
from rootdbs object.
2010-03-25 11:29:06 24644 24642 /opt/informix-11.50.fc4/bin/onbar_d
complete, returning 96 (0x60)

Error when trying to do imported restore:


2010-04-09 12:49:02 2947 2945 do_args: got command, -r
2010-04-09 12:49:02 2947 2945 do_args: got command, -p
2010-04-09 12:49:02 2947 2945 do_args: got -rename command
2010-04-09 12:49:02 2947 2945 do_args: got command, -rename
2010-04-09 12:49:02 2947 2945 do_args: got command, -w
2010-04-09 12:49:02 2947 2945 Removing the onbar_restore file
2010-04-09 12:49:02 2947 2945 do_args: workflags 65560 (0x10018)
2010-04-09 12:49:02 2947 2945 do_args: return 0 (0x00)
2010-04-09 12:49:02 2947 2945 bar_siginit: enter
2010-04-09 12:49:02 2947 2945 bar_siginit: return
2010-04-09 12:49:02 2947 2945 bar_alarm: enter
2010-04-09 12:49:02 2947 2945 bar_alarm: input 240 seconds
2010-04-09 12:49:02 2947 2945 bar_alarm: return 0 (0x00)
2010-04-09 12:49:02 2947 2945 bar_exec: enter
2010-04-09 12:49:02 2947 2945 BSAQueryApi: enter
2010-04-09 12:49:02 2947 2945 bar_loadXBSA: enter
.
.
2010-04-09 12:49:03 2947 2945 BSAGetObject: return 96 (0x60)
2010-04-09 12:49:03 2947 2945 do_xbsa_error: enter
2010-04-09 12:49:03 2947 2945 do_xbsa_error: input the_error 96
function BSAGetObject
2010-04-09 12:49:03 2947 2945 do_xbsa_error: return 138 (0x8a)
2010-04-09 12:49:03 2947 2945 barGetObject: return 96 (0x60)

Cause

The Storage Manager (SM) returns code 96 ( 0x60 ) for many reasons. Here are some of those reasons:

  • file system where SM log file resides is full
  • required SM environment variable is not set
  • required SM environment variable is set incorrectly
  • this SM client does not have permission to restore the requested backup

Resolving The Problem

Check your Storage Manager message and error logs for more information about this error. If you do not find the answer there contact your Storage Manager technical support team for additional assistance.

[{"Product":{"code":"SSGU8G","label":"Informix Servers"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF022","label":"OS X"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"10.0;11.1;11.5;11.7","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
16 June 2018

UID

swg21430054