IBM Support

FileNet Content Engine (CE) – Application Server soap port is changed after installation and deployment of CE EAR application, causing custom applications to no longer function.

Troubleshooting


Problem

After successful installation/deployment of the CE ear, the soap port on the application server, that contains the CE app, is changed; Opening the CE WSDL test URL “http://CEserver:new_soap_port/wsi/FNCEWS40SOAP/wsdl” output references the old soap port. Customer was using custom applications which were monitoring this URL and receiving the old soap port so custom applications were not functional.

Symptom

CE WSDL test URL “http://CEserver:new_soap_port/wsi/FNCEWS40SOAP/wsdl”
produces an xml output and this xml contains the old soap port reference.

Cause

During configuration and installation of the CE the soap port is hard coded into the web.xml.

Environment

ALL

Resolving The Problem

  1. Re-bootstrap the CE EAR using the new soap port
  2. Re-deploy the updated CE EAR

[{"Product":{"code":"SSNVNV","label":"FileNet Content Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Content Engine","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"4.5.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21430032