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** Troubleshooting ** "Could not start the TM1 Server xxxxxxxx service on Local Computer" when starting TM1 server

Troubleshooting


Problem

I.T. Administrator opens Windows services. Administrator highlights the relevant TM1 server service ("TM1 Server xxxxxxxx") and clicks 'start'. The Windows service tries to start, but an error appears.

Symptom

Services
Could not start the TM1 Server xxxxxxxx service on Local Computer.
Error 1067: The process terminated unexpectedly.
[OK]

Cause

There are several possible causes for the same error:

  • Scenario #1 - Windows user account (used to run the service) has an issue.
    • For example the user is not a local administrator, or the password has changed/expired
  • Scenario #2 - DataBaseDirectory has not been set correctly (in the "tm1s.cfg" file)
  • Scenario #3 - Incorrect path settings ("ImagePath" and "ConfigPath") stored in the registry
  • Scenario #4 - TM1 server's hard drive is full
  • Scenario #5 - TM1 server needs to be re-registered.

Diagnosing The Problem

Check the Event Viewer for TM1 errors, as it often gives a clue as to what the problem is. One example is shown below:

Scenario #2

    Event Viewer (Application Log)
    Event Type: Error
    Event Source: tm1sd
    Event Category: None
    Event ID: 0
    Date: 21/01/2010
    Time: 10:00:29
    User: N/A
    Computer: MYSERVERNAME
    Description:
    The description for Event ID ( 0 ) in Source ( tm1sd ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: tm1sd error: 3, Data directory not specified. Aborting server start up.

Resolving The Problem

Scenario #1 - Windows user account (used to run the service) has an issue.

  • Check to see if the password has changed for the user starting services and update it if it has changed. This happens often for users who run a TM1 server on their local machine. More often than not, this is the reason for this error.
    • => As a best practice, it should preferably be a dedicated account for all TM1 services.
  • Ensure that the Windows user must be a member of the local "Administrators" group on the server.

Scenario #2 - Incorrect DataBaseDirectory
If this is a new install (or if the data directory has changed) make sure that the correct DataBaseDirectory is set in the tm1s.cfg file.
  • By default this is located in the data directory, but yours may be in a place of your own choosing.

Scenario #3 - Incorrect path settings in registry
NOTE: Please do not attempt to modify the registry if you are not comfortable with doing so. You can always have your system admin do it for you or log a PMR and TM1 support can assist. See Microsoft link below for safety guidelines when modifying the registry.

If you need to change the path to the TM1Server executable due to a directory change you must go to the registry (Start > Run > regedit). Once there go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services and find the TM1Server name that you are trying to start.
  • If the path to the tm1sd.exe is not correct, double-click on the ImagePath, modify the path and click OK.
  • If you have also changed your data directory you would need to modify the ConfigPath in the same way.

Scenario #4
Make sure there is sufficient disk space on the TM1 server.

Scenario #5
If it still doesn't work, then remove/reinstall the TM1 service. To do that, run the following from a command prompt (Start > Run > cmd):
  • To remove the TM1 Server Windows service, run Tm1sd -remove. Tm1sd is located in the <install_dir>\bin directory. CD to the bin folder. The complete syntax for Tm1sd -remove is:
Tm1sd -remove -nServiceName
Where -n is the name of your TM1 server service.
  • To reinstall the TM1 server as a Windows service, run Tm1sd -install from a command prompt. Tm1sd is located in the <install_dir>\bin directory. CD to the bin folder. The complete syntax for Tm1sd -install is:
Tm1sd -install -nServiceName -zConfigPath -uUserName -wPassword

Then go to Services, locate the TM1Server and attempt to start it again.

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Document Information

Modified date:
15 June 2018

UID

swg21429507