IBM Support

Unable to open reports in Internet Explorer - CM-REQ-4158

Troubleshooting


Problem

When trying to open reports in IE, the following error message is displayed: CM-REQ-4158 The search path "/content/folder[@na#e='folder']/report[@name='report'] is invalid.

Cause

The Internet Explorer XSS filter is scrambling the Cognos search path, rendering it invalid.

Environment

All Windows Environments

Resolving The Problem

To resolve the issue, make the following changes to the IE browser:

- Add the Cognos URL to IE's Trusted Sites list

- Modify the options of the Trusted Sites zone and set the "Enable XSS Filter" property to "Disable"

- Restart the browser and the reports should now execute

Please note: Turning off the browser's XSS filter has little to no risk when done only on the Trusted Sites zone. The IBM Cognos BI application has an internal firewall which protects it from XSS attacks, so the browser's filter is redundant.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Cognos Connection","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.2;10.2.1;10.2;10.1.1;10.1;8.4.1","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21428246