IBM Support

Submit CR operation in Change 5.2 results in "ERROR: Failed in UI function cs_cmds:CSapi_create_cr"

Troubleshooting


Problem

Attempts to submit a CR operation in IBM Rational Change 5.2 fails with the error "Failed in UI function cs_cmds:CSapi_create_cr" and results in no new CR operations.

Symptom

CR submission fails in Change as a result of which no user is able to submit a new CR.

The following error appears during Submit CR operation in IBM Rational Change 5.2

======================
ERROR: Failed in UI function cs_cmds:CSapi_create_cr(...)
Stack trace: com.telelogic.cm.errorapi.CcmIOException: java.net.SocketException: Connection reset
at com.telelogic.cm.util.IOUtils.readAll(IOUtils.java:81)
at com.telelogic.cm.jrfc.RFC_Package.create(RFC_Package.java:114)
at com.telelogic.cm.jrfc.RFC_PackageReader.waitFor(RFC_PackageReader.java:115)
at com.telelogic.cm.jrfc.RFC_Connection.waitPackage(RFC_Connection.java:242)
at com.telelogic.cm.jrfc.RFC_RemoteObject.Call(RFC_RemoteObject.java:267)
at com.telelogic.cm.jrfc.AccentInterpreter.Call(AccentInterpreter.java:104)
at com.telelogic.cm.jrfc.utils.AccentUserInterface.uiCall(AccentUserInterface.java:287)
at com.telelogic.cm.jrfc.utils.AccentUserInterface.uiCall(AccentUserInterface.java:349)
at com.telelogic.cs.session.BackendSession.uiCall(BackendSession.java:178)
at com.telelogic.cs.session.BackendSession.uiCall(BackendSession.java:163)
at com.telelogic.cs.session.CmSession.callAccent(CmSession.java:864)
at com.telelogic.cs.session.CmSession.ExecuteCommand(CmSession.java:557)
at com.telelogic.cs.cmapi.CcmApi.PTCommandExecute(CcmApi.java:1869)
at com.telelogic.cs.cmapi.CcmApi.PTCommandExecute(CcmApi.java:1859)
at com.telelogic.cs.ChangeApi.ccmSubmitProblem(ChangeApi.java:3003)
at com.telelogic.cs.servlet.PTactionBase.do_Submit(PTactionBase.java:381)
at com.telelogic.cs.servlet.PTactionBase.SubmitAction(PTactionBase.java:1721)
at com.telelogic.cs.servlet.PTaction.PerformAction(PTaction.java:571)
at com.telelogic.cs.servlet.PTaction.doPost(PTaction.java:77)
======================

Cause

The 'ccm' chunk file lacks dbspace.

Resolving The Problem

Steps to resolve the issue is as follows:

  1. Run the following command to check chunk file space:

    ccmsrv status -a

  2. To increase the chunk file space, run the following command:

    ccmsrv expand /size kbytes /p|/path chunkpath [/y] [/d|/dbspace dbspacename]

Once expanded, the error messages will not occur again during CR submission.

[{"Product":{"code":"SSYQQ2","label":"Rational Change"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"General Information","Platform":[{"code":"PF033","label":"Windows"}],"Version":"5.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21428012