Windows Fatal Exception error - no license available from ClearCase license manager

Technote (troubleshooting)


Problem(Abstract)

This technote explains how to resolve errors, Windows - Fatal Application Exit and No license available from ClearCase license manager, that can occur when using IBM Rational ClearCase.

Symptom

End users receive a "Windows Fatal Exception" error message when performing basic ClearCase functions:

Windows - Fatal Application Exit

mvfs: ERROR: view-view-name_view vob=<vob-tag>

No license available from ClearCase license manager; use clearlicense to display license usage





ClearCase Atria Location Broker Service (ALBD) service requires restarting every 15-20 minutes on the VOB server.


The Atria Location Broker Service always displays as being started, but requires a restart to alleviate the issue.

View Log displays the following:

Error Friday, April 02, 2010 11:53:27 AM view_server 5736
view_server.exe(5736): Error: There are no valid licenses in the NT registry for ClearCase.
Error Friday, April 02, 2010 11:53:27 AM view_server 5736
view_server.exe(5736): Error: view_setwork_get_vobs failed:
No license available from Atria license manager; use clearlicense to display license usage
Error Friday, April 02, 2010 11:53:25 AM view_server 5736

view_server.exe(5736): Error: view_setwork_get_vobs failed:
No license available from Atria license manager; use clearlicense to display license usage
Error Friday, April 02, 2010 11:53:25 AM view_server 5736

view_server.exe(5736): Error: There are no valid licenses in the NT registry for ClearCase.
Error Friday, April 02, 2010 11:53:25 AM view_server 5736

view_server.exe(5736): Error: License checkout error from Rational Common Licensing:

Error: Unable to contact albd_server on host <Host-name>

Cause

This issue was caused by a permissions issue with the Atria Location Broker (ALBD) service account.

Although the error message indicates an issue with the License server, restarting the License Server has no effect in resolving the concern.


Environment

ClearCase 7.1.1
View, VOB, Registry and License Server.


Diagnosing the problem

Check for the above errors in the view log.

  1. Verify the "ALBD account" can read the following registry key and its contents:
    HKEY_LOCAL_MACHINE\SOFTWARE\Rational Software\Licensing\1.0


    Note: The registry key may be different depending on which version you are using where 7.1 uses the 2.0 key and 7.0 uses 1.0.

    Example from a ClearCase 7.1.1.1 host:
  2. Verify that the files referenced by the "LicensePerm" and "LicenseTemp" string values can be seen and read by the ALBD account.
  3. Verify that the "UseLicenseServer" value is a string reading "TRUE".


Resolving the problem

Add the ALBD service account to Local Administrators group.

Note: If the account is already present, you will need to pull it out of the group and re-add it.

Other supporting resolutions can include opening the permissions to the <Clearcase-home>\Common folder giving the ALBD account open/read and find permissions.

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Document information


More support for:

Rational ClearCase
ALBD

Software version:

7.0, 7.0.1, 7.1, 7.1.1

Operating system(s):

Windows

Reference #:

1427109

Modified date:

2010-07-21

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