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KCIIN1145E Unable to start Tivoli Enterprise Portal Server


Technote (troubleshooting)


Problem(Abstract)

The following error message is received when starting TEPS from CandleManage on Linux :
"KCIIN1145E Unable to start Tivoli Enterprise Portal Server"

Cause

A corrupted key database prevents the Tivoli Enterprise Portal Server (TEPS) from starting.

Diagnosing the problem

You will need to review the TEPS logs to determine if you are facing this error:

1) Change directory to Tivoli Storage Manager Reporting and Monitoring installation directory, the default directory is "/opt/tivoli/tsm/reporting/itm"

2) Change directory to the "logs" to see all the logs generated for all components. The logs are named based on their components. Review the Understanding Tivoli Storage Manager Reporting and Monitoring logs document for more information on log naming convention.

3) The TEPS logs will contain the '_cq_' letters. Search all log files associated with this qualifier within the logs directory via 'ls -l grep *cq*'. This will list all the logs that are generated for TEPS. Review the latest log file for the errors. The errors will be similar to the following:

(4A5254F6.0002-7754:ctsecureadapt.cpp,316,"KFW_initCryptoContext") Failed in GSKKM_OpenKeyDb
(4A5254F6.0003-7754:ctserver.cpp,1220,"CTServer::initORB") Failed to initialize the cryto conext. Return code 10
(4A5254F6.0004-7754:kbbssge.c,52,"BSS1_GetEnv") KGL_MSG2_EVENTLOG="FORMAT /tivoli/IBM/ITM/logs/kfwservices.msg"
(4A5254F6.0005-7754:ctserver.cpp,2077,"CTServer::exitProcess") KFW1049E Process exit code: 2, exit from main


Resolving the problem

The cause of the problem is that the key database in GSKit is corrupted. A key database is the structure used to store keyfiles (digital certificates). To resolve this problem, perform the following steps:

1) Stop all ITM components on the system

2) Move/remove the <ITMHOME>/keyfiles directory. For the TSM Reporting and Monitoring, the default installation directory is '/opt/tivoli/tsm/reporting/itm'.

3) Issue the following from the <ITMHOME>/bin directory:

installGSkit

4) Enter the encryption key when prompted or use the default key

NOTE: If you are not asked for the encryption key after running the installGSkit command, you will need to run the install.sh script from the ITM install media. For this process:

a) Issue the install.sh command, the install.sh should be located in the package that you extract in the following location '/COI/PackageSteps/ITM_6.x/FILES/install.sh'

b) Enter the ITM home directory.

c) Select 1) Install products to the local host.

d) Accept the license agreement

e) Enter the encryption key or accept the default

f) At the next prompt, you can exit from the installation

At this point, the keyfiles directory and files contained within it should be recreated and you should be able to successfully start the TEPS.


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Document information

Tivoli Storage Manager


Software version:
6.1, 6.2


Operating system(s):
Linux


Software edition:
All Editions


Reference #:
1426592


Modified date:
2010-04-19

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