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DB2 install failure on Windows reporting -2079391743 and Access denied errors

Technote (troubleshooting)


Problem(Abstract)

DB2 install failes on Windows Vista and higher with error number -2079391743, along with an access denied error.

Symptom

The install of DB2 will fail and you will see the following messages in the install log file.

Action 17:21:46: DB2CustomAction. Creating the DB2 Administration Server
1: ERROR:An error occurred while creating the user "db2admin" for the DB2
Administration Server. The return value is "5130".
 
Action 17:21:57: DB2CustomAction. Creating the DB2 Administration Server
1: Creating the DB2 Administration Server:.......Failure
Action 17:21:57: DB2CustomAction. Setting default global profile registry variables
1: ERROR:An error occurred while initializing the Profile Registry. The return
value is "-2079391743". Contact your technical service representative.
 
1: ERROR:The value "DB2PATH=C:\IBM\SQLLIB" could not be added to the Global Profile Registry. Return value is "-2079391743".
 
1: ERROR:An error occurred while setting the registry key
"SOFTWARE\Microsoft\MSDTC\XADLL\C:\IBM\SQLLIB\BIN\DB2APP.DLL" to
"C:\IBM\SQLLIB\BIN\DB2APP.DLL".
 
1: ERROR:The value "DB2INSTDEF=DB2" could not be added to the Global Profile Registry. Return value is "-2079391743".
 
1: ERROR:The value "DB2_EXTSECURITY=NO" could not be added to the Global Profile Registry. Return value is "-2079391743".
 
1: ERROR:The value "DB2SYSTEM=testsys" could not be added to the Global Profile Registry. Return value is "-2079391743".
 
Action 17:22:17: DB2CustomAction. Configuring DB2 instances
1: Configuring DB2 instances:.......Failure
Action 17:22:18: DB2CustomAction. Configuring DB2 EXTENDED SECURITY
Action 17:22:20: DB2CustomAction. Configuring DB2 EXTENDED SECURITY
1: Configuring DB2 EXTENDED SECURITY:.......Success
Action 17:22:20: DB2CustomAction. Configuring Remote Command Service
1: ERROR:An unknown error has occurred. The text associated with the error is
"Access is denied.  ". If you require additional assistance contact a technical
service representative.


Cause

The user account used to install a DB2 server product needs to be a member of the local admin group, or a non-admin user with elevated privileges (so the install is executed under the LocalSystem account). The recent Windows operating systems, Vista and higher, strip off some of the user privileges/authorities from the local admin users, as it treats all user accounts as non-admin by default.

Because of this, the installation user account does not have the required privileges to execute the failing tasks (create a new account ("db2admin"), create new registry keys, configure and start Window services, etc), as noted in the installation log file.


Resolving the problem

Launch the install with the "Run as Administrator" option.

  • If the install is launched from a command window, for example with the "setup.exe" command, then the command window should be opened with the "Run as Administrator" option. You can do that by right clicking the shortcut when you open the command window.
  • If the install is launched by clicking on the "setup.exe" executable, you should right click setup.exe and choose the option "Run as Administrator".

Document information

More support for: DB2 for Linux, UNIX and Windows
Install/Migrate/Upgrade - Database

Software version: 9.5, 9.7

Operating system(s): Windows

Reference #: 1425339

Modified date: 18 November 2015