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IBM Rational Synergy Web-Mode client receive error: Session Manager Resource Error

Question & Answer


Question

What setting can you change in you IBM Rational Synergy CCM_SERVER installation to stop this error from occurring?

Cause

This problem occurs when the Rational Synergy CCM_SERVER exceeds the default time-out setting and needs to refresh connection to the Rational Directory Server.

Answer

You can decrease the possibility of this happens by increasing this time-out setting as stated below.
The file you will need to change is the TDSConfiguration.xml file. It is located a path similar to the one below.

  1. Open the TDSConfiguration.xml file located in paths similar to the ones below:\
    • Windows:
      C:\Program Files\IBM\Rational\Synergy\7.1\etc\TDSConfiguration.xml
    • UNIX:
      $CCM_HOME/etc/TDSConfiguration.xml

  2. Edit the following line below.

    BEFORE:
    <entry key="LDAP_CONNECTION_TIMEOUT">2000</entry>

    AFTER:
     <entry key="LDAP_CONNECTION_TIMEOUT">10000</entry>

  3. Save the configuration file.

    Note: The values mentioned above may need to be increased depending on your configuration.

  4. Restart the Rational Synergy CCM_SERVER daemon or service.

[{"Product":{"code":"SSC6Q5","label":"Rational Synergy"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Directory Server","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF010","label":"HP-UX"}],"Version":"7.1a;7.1.0.1;7.1;7.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
22 December 2020

UID

swg21425118