IBM Support

Test connection in Rational Performance Tester result: IWAT0284E

Troubleshooting


Problem

Attempts to test the connection to agent computers yields security message "the Agent Controller is not available on host ".

Symptom

The full error message reads as follows.

Connection failed on host <host name>.

Reason:

IWAT0284E The Agent Controller is not available on host <host name>

 Make sure that:

* for localhost, the Internal Agent Controller is supported on your local

platform.

* the Agent Controller is installed.

* the Agent Controller is configured to communicate with your machine.

* you have the correct host name and port number for the Agent

Controller.

See the workspace Error Log or Agent Controller serviceconfig.log for any

additional information.

 


Under details you see.



org.eclipse.hyades.internal.execution.local.control.
AgentControllerUnavailableException


STEPS TO REPRODUCE

  1. Click Window > Preferences.

  2. Expand Agent Contoller. Then, click Hosts.

  3. Highlight the agent computer. Then, click Test Connection.




Case A: The agent computer is the local host

You test the connection to the local host.
A Test runs error free.

Case B: The agent computer is a remote host

The remote hosts are running the Agent Controller service but the error is still occurring.


Note
The test connection function does not apply to versions 8.3 and newer, Use the Agent Status button from the toolbar instead.

Cause


Case A

  1. The definition of the local host as Location is lacking.
  2. The local host does not have the Agent Controller software.
  3. The IBM Rational Agent Controller service is not running.


Case B
    The 10002 port is closed.

Diagnosing The Problem

Case B

Run the following command from the command-line to verify that the port is open.


telnet <host> <port>

Resolving The Problem


Case A

  1. Define the local host as Location.
  2. Install the Agent Controller through the IBM Installation Manager.
  3. Start the IBM Rational Agent Controller.


Case B
    Ask your network administrator to open port 10002.

[{"Product":{"code":"SSMMM5","label":"IBM Rational Performance Tester"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Agent Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0;8.0;8.1;8.1.1;8.2;8.2.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21424848