IBM Support

Clicking Cancel in User Properties for a newly created user could cause data inconsistency

Troubleshooting


Problem

This technote identifies an issue that can occur in the IBM Rational ClearQuest User Administration Tool. A "MasterdataObject" error occurs if you create a users, reopen the User properies, and click the Cancel button all before saving your changes to the database.

Symptom

You add a new user. You then open the User Properties of that new user again. Click Cancel or X to close the User Properties screen. The user will not be added. After doing this, you might also get this error every time you open User Administration:

ERROR! An Error was detected retrieving information from the ClearQuest Database.

There is a reference to an object that does not exist:
Object Type: MasterdataObject
Object: <master_dbid>
This error was detected at: ClearQuest Core:admasterdatamgr.cpp:3243
Recommendation: if you cannot determine how to resolve this issue, contact Rational Support and provide all the above information as well as a description of the context in which the message occurred.



Steps to reproduce:

  1. Add a new user. Select group(s) for the user in User Administration.
  2. Click OK to close User Properties.
  3. Double-click the newly added user to see the User Properties screen.
  4. Click Cancel or X to close User Properties.
  5. Close User Administration (Optionally Upgrade user databases before closing).
  6. Open User Administration. You will get the MasterdataObject error.

Cause

This issue was identified as a product defect under APAR PM08376.

Note: A similar error message can occur as the result of database communication problems or other, separately identified defects. See the Related information section of this technote for more information.

Resolving The Problem

The defect is fixed starting in ClearQuest versions 7.0.1.9 and 7.1.1.2. It is recommended that you upgrade to the latest fix pack to avoid encountering this problem.


WORKAROUND: Prevention and remedy for the error message

To prevent the problem from occurring in unresolved versions, make sure to click OK in User Properties for a newly added user. Do not click the Cancel or X button before you save the change by closing User Administration.

To remove the MasterdataObject error, contact IBM Rational Support for further assistance.


BACKING UP FILES

Always make new database back-ups of your schema repository and user databases prior to making schema changes and performing database upgrades. Failure to create back-up copies can limit your ability to recover from a an upgrade failure, design change issues or other unforeseen failures.

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Document Information

Modified date:
29 September 2018

UID

swg21424646