What is needed to search through PDF and Microsoft Office files in AppScan Enterprise

Technote (troubleshooting)


Problem(Abstract)

When searching with IBM Rational Policy Tester and IBM Security AppScan Enterprise for strings using built-in xrules, the string is not being found in the .pdf files and Microsoft Office (Excel) files.

Symptom

To scan properly PDF files and Windows Office files, you need to select options under: "Advanced Scan Configuration -> Explore Options -> Link and Content Extraction":

    • Parse PDF to discover URLs and content
    • Parse Office documents to discover URLs and content

However, after the above settings, AppScan Enterprise still does not search through PDF and Microsoft Office files.

The ItemLog may show the following error:
Extraction utility not found: C:\Program Files (x86)\ibm\Rational ASE\filtdump.exe

Cause

You need to install additional software.

Resolving the problem

You need to install the following software on the ASE server machine:

  • Copy filtdump.exe file into the Policy Tester install directory.
    (This is a Microsoft tool that allows extracting text from various types of documents)
    How to get filtdump.exe?
  • Install Adobe IFilter.

  • Install Windows Search (needed for filtdump.exe to work properly on Windows)
    Windows search is an optional component in server 2008. You have to enable the file server role to get it.
    Install it in the following way: If you are in Server Manager, highlight roles. Read down the screen on the right. If you have installed File Services Role, you will see "Role Services" under the File Services section. Click on "Add Role Services" on the right. Click to add Windows Search Service.


Cross reference information
Segment Product Component Platform Version Edition
Security Rational Policy Tester 5.6, 8.5, 8.5.0.1, 8.5.0.2, 8.5.0.3

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

IBM Security AppScan Enterprise
Configuration

Software version:

5.6, 8.0, 8.5

Operating system(s):

Windows

Reference #:

1424330

Modified date:

2013-02-13

Translate my page

Machine Translation

Content navigation