IBM Support

db2start fails with SQL8000N

Troubleshooting


Problem

After install or upgrade of Tivoli Storage Manager Server V6, the server may fail to start with SQL1032N and the db2start may fail with error SQL8000N

Symptom

The "db2start" command fails with the following errors :

SQL8000N DB2START processing failed; a valid product license was not found. If you have licensed this product, ensure the license key is properly registered. You can register the license via the License Center or db2licm command line utility. The license key can be obtained from your licensed product CD.
SQL1032N No start database manager command was issued. SQLSTATE=57019

Cause

The DB2 license was not activated or db2iupdt failed

Environment

Tivoli Storage Manager Server V6 on UNIX and Linux

Resolving The Problem

The following steps can be used to resolve the issue:

Login or su to the TSM DB2 instance owner and run the "db2licm -l" command.

  • If the command returns license as "Expired", for example:

  • Product name: "DB2 Enterprise Server Edition"
    Expiry date: "Expired"
    Product identifier: "db2ese"
    Version information: "9.7"

    then proceed with the following steps:

    a: Run the following command:

    find / -name db2ese.lic

    Notes:
    - db2ese.lic is normally located under "/extract_dir/COI/PackageSteps/DB2_9.7/FILES/ese/db2/license"
    - /extract_dir is the directory where the Tivoli Storage Manager package is extracted.

    b: Switch to the directory where the db2ese.lic is located and run the below command. For example:

    $cd /extract_dir/COI/PackageSteps/DB2_9.5/FILES/ese/db2/license
    $db2licm -a db2ese.lic
    LIC1402I License added successfully.
    LIC1426I This product is now licensed for use as outlined in your License Agree ment. USE OF THE PRODUCT CONSTITUTES ACCEPTANCE OF THE TERMS OF THE IBM LICENSE AGREEMENT, LOCATED IN THE FOLLOWING DIRECTORY: "/opt/tivoli/tsm/db2/license/en_US.iso88591"


    c: test db2start/db2stop before starting the Tivoli Storage Manager server.

  • If the command returns the license as "Permanent", for example:

  • Product name: "DB2 Enterprise Server Edition"
    License type: "Restricted"
    Expiry date: "Permanent"
    Product identifier: "db2ese"
    Version information: "9.7"

    then proceed the following steps:

    a:Run the following command :

    /opt/tivoli/tsm/db2/instance/db2iupdt tsminst1

    It should complete with the following message :

    DBI1070I Program db2iupdt completed successfully


    b: test db2start/db2stop before starting Tivoli Storage Manager server.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21423162