IBM Support

Extracting data from Java Health Center

Technote (troubleshooting)


Problem(Abstract)

How to extract data from the Java™ Health Center and submit to IBM Support for analysis.

Symptom

Collecting data from Java Health Center:


Resolving the problem

There may be times when IBM Support asks for the output from the Java Health Center.

To save Java Health Center data:

  1. With Java Health Center running, click File->Save Data:

  2. The default extension is *.hcd and it is recommended to name the file something descriptive such as "<PMR #>.<ProblemType>.<date>.hcd". ex: "12345.123.123.highCpu.20150409.hcd"
  3. Save the file. This will save the last 300MB of data read by the Health Center.
  4. Submit to IBM Support:
    IBM Exchanging information with IBM Technical Support for problem determination

To load the data back into Java Health Center:
  1. With Java Health Center Running click File->Load Data...
  2. Locate the proper *hcd file and click "Open"
  3. The data from the saved file will be displayed.


More information can be found under the Help Menu in Java Health Center or in the online IBM Knowledge Center

Document information

More support for: WebSphere Application Server
Hangs/Performance Degradation

Software version: 6.1, 7.0, 8.0, 8.5

Operating system(s): AIX, Linux, Windows

Reference #: 1423006

Modified date: 31 March 2010


Translate this page: