Migrating projects from Optimization Service Center to Data Studio (stand-alone version)

Technote (FAQ)


Question

How do I migrate projects from Optimization Service Center to Data Studio (stand-alone version)?

Answer

Export your projects from Optimization Service Center, migrate the EXPLAIN tables and Optimization Service Center tables that are on your DB2 for z/OS subsystems, and then import your exported projects into Data Studio (stand-alone version).

1. Export projects from Optimization Service Center.

Follow these steps to export a project that was created in Optimization Service Center.

  1. In Optimization Service Center, select Project > Export.
  2. In the Export Project window, select the project that you want to export.
  3. Select the directory to which you want to export the project.
  4. Click Finish.
In the directory that you specified, Optimization Service Center creates a .zip file that contains the project.

2. Migrate EXPLAIN tables and Optimization Service Center tables on DB2 for z/OS subsystems.

Follow these steps to use Data Studio (stand-alone version) to migrate the EXPLAIN tables for each of the DB2 for z/OS subsystems that are used in Optimization Service Center. If you want to migrate the tables manually, customize and run the DSNTIJOS sample JCL job instead; then, follow steps 1 through 3 below to establish a connection from Data Studio (stand-alone version) to the subsystem.

  1. In Data Studio (stand-alone version), open the Data perspective if it is not already open. Select Window > Open Perspective. If you do not see Data listed, click Other and select Data in the Open Perspective window.
  2. If a connection to the subsystem exists in the Data Source Explorer, which is in the lower-left corner: Right-click the connection and select Connect. After the connection is open, select the database node and then select the connection node again.
  3. If a connection to the subsystem does not exist in the Data Source Explorer, which is in the lower-left corner: Configure a connection to the DB2 for z/OS subsystem that you are using with the Optimization Service Center.
    1. Right-click the Database Connections folder and select New.
    2. In the New Connection wizard, select DB2 for z/OS in the list of database managers.
    3. Select the JDBC driver to use for connections to the subsystem.
    4. On the General page under Properties, specify the connection information.
    5. Click Finish.
    6. In the Data Source Explorer, select the connection.
  4. In the Properties view, click the Query Tuner Status tab and click Bind. The Configure Database for Tuning wizard opens to the Bind Packages page.
  5. Select the Basic Query Tuner package and the Static Advisor package under Single Query Tuner. These packages together contain the following features:
    • Capture queries from all sources
    • Formatted query
    • Access Plan Graphs (also known as Visual Explain)
    • Query Report
    • Statistics Advisor
    • Query environment capture
  6. Click OK when you see the prompt to migrate the EXPLAIN table DSN_PTASK_TABLE.
  7. In the Properties view, click the Create or Drop button for workload tables. The Configure Database for Tuning wizard opens to the Manage Workload Tables page.
  8. Click Create Tables. Click OK to any prompts to migrate existing tables.
  9. In the Properties view, click the Create or Drop button for the statistics profile table and create that table in the Configure Database for Tuning wizard.

3. Import projects into Data Studio (Stand-Alone Version).

Follow these steps to import into Data Studio (stand-alone version) the projects that you exported from Optimization Service Center.

  1. In the Data Studio (stand-alone version), select File > Import.
  2. In the Import window, select Query Tuner > Projects.
  3. For the root directory, select the directory that contains the .zip file for the project.
  4. Select the project and click Finish.
  5. Expand the project and double-click the node that is labeled No connection profile is bound for the project.
  6. In the window that opens, choose the connection to the same data source that the project used in its original location or to a compatible data source.
  7. Click OK.

Cross Reference information
Segment Product Component Platform Version Edition
Information Management Data Studio Windows 2.2, 2.2.0.1 IBM Data Studio

Rate this page:

(0 users)Average rating

Document information


More support for:

DB2 for z/OS
Optimization Service Center

Software version:

8.0, 9.1

Operating system(s):

z/OS

Reference #:

1420957

Modified date:

2010-02-16

Translate my page

Machine Translation

Content navigation