ITCAM TEMA does not connect to Data Collector.

Technote (troubleshooting)


This document applies only to the following language version(s):

US English

Problem(Abstract)

ITCAM DC is connected to the Managing Server, but does not appear to be connected to the TEMA. The ITCAM agent is online in the TEP, but the JVM does not appear under it in the navigation tree. There are no workspaces.

Symptom

Unable to expand ITCAM WebSphere navigator in TEP. The JVM does not appear under the navigator tree.


Cause

The Data Collector MBeans that are required for the TEMA are not loading correctly due to permission issue. Look at the following directory and make sure the "read" permission is present for toolkit_config_kwj.xml (and also other files.) Ensure the owner and group that is for the Websphere process is the same for the below files as well.


/opt/candle/itcam/WebSphere/DC/itcamdc/etc:
toolkit_config_ctg.xml
toolkit_config_ims.xml
toolkit_config_jdo.xml
toolkit_config_kwj.xml
toolkit_config_mqi.xml
toolkit_config_ra.xml
toolkit_custom.properties

Diagnosing the problem

Check Permission's as well as owner/group for file:

/opt/candle/itcam/WebSphere/DC/itcamdc/etc/tookit_config_kwj.xml

to make sure the owner/group is same as WebSphere.


Resolving the problem

Changed owner/group for all files and directories to match the owner and group for the WebSphere Process.

Product Alias/Synonym

ITCAMforWebSphere

Rate this page:

(0 users)Average rating

Document information


More support for:

Tivoli Composite Application Manager for WebSphere
ITCAM for WebSphere (Dist)

Software version:

6.1

Operating system(s):

AIX, HP-UX, Linux, Solaris

Reference #:

1419811

Modified date:

2013-07-24

Translate my page

Machine Translation

Content navigation