System requirements for WebSphere Dashboard Framework 6.1.5

Technote (troubleshooting)


Problem

This document contains the detailed system requirements for WebSphere Dashboard Framework 6.1.5.

Resolving the problem

    System requirements for WebSphere Dashboard Framework 6.1.5

    For all platforms, IBM WebSphere Portlet Factory 6.1.5 is required.

    Windows
    Development environment
    Operating systems (required)
    • Microsoft Windows 2003 Standard and Enterprise Editions
    • Microsoft Windows XP Professional
    • Microsoft Windows Vista Business and Ultimate
    Integrated Development Environments (optional)
    • IBM Rational Application Developer 7.5
    • IBM Rational Software Architect 7.5
    • IBM WebSphere Integration Developer 6.2
    • Eclipse SDK 3.4 (requires Web Tools 3.0)

    Deployed applications

    WebSphere Portal servers (required)
    • IBM WebSphere Portal 6.1.0.x, *6.1.5.x, 7.0.0.x
    • IBM Lotus Quickr services for WebSphere Portal (Lotus Quickr 8.0, 8.1). For more information, search the WebSphere Dashboard Framework product category for tech notes related to Quickr.
    • IBM WebSphere Portal Express 6.1.0.x, *6.1.5.x, 7.0.0.x

    NOTE: While the Portlet Factory generates JSR-168 and JSR-286 compliant applications, IBM provides no support for specific JSR-168 and JSR-286 portlet containers other than WebSphere Portal and WebSphere Application Server.

    WebSphere Portal operating systems (required)
    • Microsoft Windows Server 2003 Standard, Datacenter, Enterprise, R2 and SP2
    • Microsoft Windows Server 2008
    • Microsoft Vista (development only)

    Application Servers (required)
    • IBM WebSphere Application Server 6.1.x, 7.0
    • Apache Tomcat Server 6.x (Development use only)
    • WebSphere Application Server Community Edition 2.0, 2.1 (Development use only)

    Supported rich clients (optional)
    • IBM Lotus Expeditor 6.1.1 and later (for rich client deployment)
    • IBM Lotus Notes 8 Standard and later (for rich client deployment)

    Supported JDK versions (required)
    • Java 2 SDK, Standard Edition v1.5

    Browsers (required)
    • Microsoft Internet Explorer 6.0 SP1 (SP2 for Windows XP)
    • Microsoft Internet Explorer 7.0
      NOTE: Tree builder users must click twice to open and expand the nodes of the tree.
    • Microsoft Internet Explorer 8.0
    • Mozilla Firefox 1.5.0.7, 2.0.x, 3.0,3.5.x
      NOTE: When you use Firefox as the browser for running models from WebSphere Portlet Factory Designer, close the tab that displays the running model before re-running the model from the Designer.
    • *Apple Safari 3.1 (to support iPhone)

    Enterprise Integrations

    Databases (optional)
    • IBM DB2 Enterprise Edition 8.x, 9.1, 9.5
    • Microsoft SQL Server 2005 (requires msbase.jar, mssqlserver.jar, and msutil.jar)

    Supported IBM products (optional)
    • IBM Lotus Quickr 8.0, 8.1
    • IBM Lotus Mashups 1.1,*2.0
    Supported business intelligence systems (optional)
    • Business Objects Enterprise XI R2
    • Cognos BI 8.1, 8.2, 8.3, *8.4
    • Hyperion Essbase 7.x and 9.x
    • *Microsoft SQL Server Analysis Service 2005, and 2008

    Lotus Domino, SAP, Siebel, and PeopleSoft systems are all supported through WebSphere Portlet Factory. See the Portlet Factory 6.1.5 information center for more information.
    AIX
    Deployed applications

    WebSphere Portal servers (required)
    • IBM WebSphere Portal 6.1.0.x, *6.1.5.x, 7.0.0.x

    NOTE: While the Portlet Factory generates JSR-168 and JSR-286 compliant applications, IBM provides no support for specific JSR-168 and JSR-286 portlet containers other than WebSphere Portal and WebSphere Application Server.

    WebSphere Portal operating systems (required)
    • IBM AIX 5.x, 6.1 FP4

    Application Servers (required)
    • IBM WebSphere Application Server 6.1.x, 7.0
    • WebSphere Application Server Community Edition 2.0, 2.1 (Development use only)

    Supported JDK versions (required)
    • Java 2 SDK, Standard Edition v1.5

    Browsers (required)
    • Microsoft Internet Explorer 6.0 SP1 (SP2 for Windows XP)
    • Microsoft Internet Explorer 7.0
      NOTE: Tree builder users must click twice to open and expand the nodes of the tree.
    • Microsoft Internet Explorer 8.0
    • Mozilla Firefox 1.5.0.7, 2.0.x, 3.0, 3.5.x
      NOTE: When you use Firefox as the browser for running models from WebSphere Portlet Factory Designer, close the tab that displays the running model before re-running the model from the Designer.
    • *Apple Safari 3.1 (to support iPhone)
    Enterprise Integrations

    Databases (optional)
    • IBM DB2 Enterprise Edition 8.x, 9.1, 9.5
    Supported business intelligence systems (optional)
    • Business Objects Enterprise XI R2
    • Cognos BI 8.1, 8.2, and 8.3, *8.4
    • Hyperion Essbase 7.x and 9.x
    • *Microsoft SQL Server Analysis Service 2005, and 2008

    Lotus Domino, SAP, Siebel, and PeopleSoft systems are all supported through WebSphere Portlet Factory. See the Portlet Factory 6.1.5 information center for more information.

    Linux

    Development environment

    Operating systems (required)
    • Red Hat Enterprise Linux 5.1
    • SUSE Linux Enterprise Desktop 10

    Integrated Development Environments (optional)
    • IBM Rational Application Developer 7.5
    • IBM Rational Software Architect 7.5
    • IBM WebSphere Integration Developer 6.2
    • Eclipse SDK 3.4 (requires Web Tools 3.0)

    Deployed applications

    WebSphere Portal servers (required)
    • IBM WebSphere Portal 6.1.0.x, *6.1.5.x, 7.0.0.x
    • IBM Lotus Quickr services for WebSphere Portal (Lotus Quickr 8.0, 8.1). For more information, search the WebSphere Dashboard Framework product category for tech notes related to Quickr.
    • IBM WebSphere Portal Express 6.1.0.x, *6.1.5.x, 7.0.0.x

    NOTE: While the Portlet Factory generates JSR-168 and JSR-286 compliant applications, IBM provides no support for specific JSR-168 and JSR-286 portlet containers other than WebSphere Portal and WebSphere Application Server.

    WebSphere Portal operating systems (required)
    • Red Hat Linux Server 5.1 ES/AS
    • SUSE Linux 9.0 SP4 (development only)
    • Red Hat Enterprise Linux WS v4 update 6 (development only)
    • Red Hat Desktop Version 4 update 6 (development only)
    Application Servers (required)
    • IBM WebSphere Application Server 6.1.x, 7.0
    • Apache Tomcat Server 6.x (Development use only)
    • WebSphere Application Server Community Edition 2.0, 2.1 (Development use only)

    Supported rich clients (optional)
    • IBM Lotus Expeditor 6.1.1 and later (for rich client deployment)
    • IBM Lotus NOTEs 8 Standard and later (for rich client deployment)
    Supported JDK versions (required)
    • Java 2 SDK, Standard Edition v1.5

    Browsers (required)
    • Microsoft Internet Explorer 6.0 SP1 (SP2 for Windows XP)
    • Microsoft Internet Explorer 7.0
      NOTE: Tree builder users must click twice to open and expand the nodes of the tree.
    • Microsoft Internet Explorer 8.0
    • Mozilla Firefox 1.5.0.7, 2.0.x, 3.0,3.5.x
      NOTE: When you use Firefox as the browser for running models from WebSphere Portlet Factory Designer, close the tab that displays the running model before re-running the model from the Designer.
    • *Apple Safari 3.1 (to support iPhone)

    Enterprise Integrations

    Databases (optional)
    • IBM DB2 Enterprise Edition 8.x, 9.1, 9.5
    • IBM DB2 for Linux on zSeries v8.1 FP15

    Supported IBM products (optional)
    • IBM Lotus Quickr 8.0, 8.1
    Supported business intelligence systems (optional)
    • Business Objects Enterprise XI R2
    • Cognos BI 8.1, 8.2, 8.3, and *8.4
    • Hyperion Essbase 7.x and 9.x
    • *Microsoft SQL Server Analysis Service 2005, and 2008

    Lotus Domino, SAP, Siebel, and PeopleSoft systems are all supported through WebSphere Portlet Factory. See the Portlet Factory 6.1.5 information center for more information.
    Solaris

    Deployed applications

    WebSphere Portal servers (required)
    • IBM WebSphere Portal 6.1.0.x, *6.1.5.x, 7.0.0.x

    NOTE: While the Portlet Factory generates JSR-168 and JSR-286 compliant applications, IBM provides no support for specific JSR-168 and JSR-286 portlet containers other than WebSphere Portal and WebSphere Application Server.

    WebSphere Portal operating systems (required)
    • Sun Solaris 9 and 10 (latest patch level required)

    Application Servers (required)
    • IBM WebSphere Application Server 6.1.x, 7.0
    • WebSphere Application Server Community Edition 2.0, 2.1 (Development use only)

    Supported JDK versions (required)
    • Java 2 SDK, Standard Edition v1.5
    Browsers (required)
    • Microsoft Internet Explorer 6.0 SP1 (SP2 for Windows XP)
    • Microsoft Internet Explorer 7.0
      NOTE: Tree builder users must click twice to open and expand the nodes of the tree.
    • Microsoft Internet Explorer 8.0
    • Mozilla Firefox 1.5.0.7, 2.0.x, 3.0, 3.5.x
      NOTE: When you use Firefox as the browser for running models from WebSphere Portlet Factory Designer, close the tab that displays the running model before re-running the model from the Designer.
    • *Apple Safari 3.1 (to support iPhone)
    Enterprise Integrations

    Databases (optional)
    • IBM DB2 Enterprise Edition 8.x, 9.1, 9.5
    Supported business intelligence systems (optional)
    • Business Objects Enterprise XI R2
    • Cognos BI 8.1, 8.2, 8.3, *8.4
    • Hyperion Essbase 7.x and 9.x
    • *Microsoft SQL Server Analysis Service 2005, and 2008

    Lotus Domino, SAP, Siebel, and PeopleSoft systems are all supported through WebSphere Portlet Factory. See the Portlet Factory 6.1.5 information center for more information.


Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

WebSphere Dashboard Framework

Software version:

6.1.5

Operating system(s):

Linux, Windows

Software edition:

All Editions

Reference #:

1419194

Modified date:

2011-05-01

Translate my page

Machine Translation

Content navigation