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Digital signature verification failure in DataPower SOA appliance.

Question & Answer


Question

Why does digital signature verification fail on a WebSphere DataPower SOA appliance?

Answer

Error:
'Hash values do not match.' - This is returned for detached and enveloping signatures.
'Incorrect reference digest value' - This is returned for enveloped-signatures.

Cause:
The hash DataPower generated of the reference node(s) did not match the hash provided by the original signer in the DigestValue node. Typically this is caused by one of the following:

  • The processing policy modified the data
  • The message was modified by a intermediate node
  • Improper handling by the signing application
 

Error:


'RSA signature did not verify' - This is thrown for errors that occur while comparing the provided RSA signature to the generated version.

Cause:
The most common causes are as follows:

  • The device has an HSM that has not been initialized. RSA operations are not available on HSM enabled devices until the unit is initialized.  For details on the initialization process, see Intializing the HSM
  • The private key used to sign the request does not match the specified certificate. If both keys are already stored on DataPower, you can confirm that the keys match using an IDCred. If it is up after adding both keys, they match, otherwise they may not.
  • The SignedInfo nodeset was modified after the signature was generated. This may occur for the same reasons as the hash/digest mismatch.
  • The SignatureValue itself was modified.
  • The signature verification is performed using a custom style sheet that is not implemented properly.

If you are still unable to verify digital signatures after investigating the causes above, contact DataPower support.

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Document Information

Modified date:
04 October 2021

UID

swg21418624