Technote (troubleshooting)
Problem(Abstract)
When opening any DB2 GUI tool the folowing error maybe seen: DB2JAVIT : RC = 9505.
Cause
The reason for the error is because the user ID does not have privileges to access the files in the DB2 installation directory (i.e. C:\Program Files\IBM\SQLLIB) due to the extended security feature. With this feature enabled, only administrators and users that belong to the extended security groups DB2USERS or DB2ADMNS will be able to access the install directory and will be able to launch the GUI tools. Please note that on UAC enabled operating systems like Windows Vista, 7, and 2008, administrators may still need to be added to DB2USERS or DB2ADMNS as Windows does not include the full administrator access token when logged in.
For more information on this please see the following Microsoft doc:
Resolving the problem
Verify that the user ID that is trying to open the DB2 GUI tool is part of the Windows groups DB2ADMNS and DB2USERS. To do this:
- Go to Start
- Control Panel
- Administrative Tools
- Computer Management
- Local Users and Groups
- Groups
You should see the groups DB2ADMNS and DB2USERS. Verify that the user ID you are trying to open the GUI tool with is part of these groups. If user ID is not part of the groups, manually add the user ID to the groups.
Related information
DB2 and Windows security introduction
Rate this page:
Copyright and trademark information
IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.