Collecting data for IBM Content Classification

Technote (FAQ)


Question

This technote describes the background information that IBM Software Support needs for analyzing issues relating to IBM Content Classification (formerly known as IBM Classification Module). Collecting this information, also known as MustGather data, before you call IBM Software Support helps in problem determination and can save time when resolving Problem Management Records (PMRs).

Answer

Collecting MustGather data early, even before opening a PMR, helps IBM Software Support quickly determine the cause of the problem. With this information, IBM Software Support can determine if this is a known problem (rediscovery) or a new problem for which a fix is required.

For information about collecting data for Content Classification version 8.8, see Collecting data for Content Classification problems in the Content Classification version 8.8 information center.

If you use version 8.7 or earlier, see the following sections.

Collecting general information

To help IBM Software Support find a solution, copy the following questions into a document or email and answer each question.

Problem Description

  • What is the problem? Provide a detailed description.
  • Is the problem reproducible? If it is reproducible, describe the detailed steps that must be followed to reproduce the problem.
  • If you see messages, what messages do you see and where do they occur?
  • When did you start seeing this problem?
  • How frequently does the problem occur?
  • How does the problem impact your business?

Environment
  • What Classification Module version do you have? Provide the version number, fix pack level, and any test fixes. If you installed any test fixes, ensure that the executable bit is enabled for the programs after the files were extracted from the compressed file.
  • What is the operating system type and version, including patches and service pack levels? To check the system requirements for Classification Module, see the link to the Classification Module system requirements in the Related information section below.
  • How much free disk space is available on each computer on which Classification Module is installed?
    • On AIX, Linux, or Solaris, run the command df -k. Provide IBM Software Support with a screen capture of the output from the command.
    • On Windows, open Computer. Provide IBM Software Support with a screen capture that shows the memory usage for your hard drives.
  • On AIX or Linux, gather the following information:
    • Gather information about CPU utilization, disk I/O, memory statistics, and network I/O by running the nmon utility with the c, d, m, and n options. Provide IBM Software Support with three screen captures of the nmon utility output, waiting 30 seconds between each screen capture.
    • Gather a list of files that are opened by Classification Module processes by running the lsof | grep bns command. Provide IBM Software Support with a screen capture of the output from the command.
  • On Windows, gather information about CPU utilization and memory statistics by opening the Windows Task Manager. Provide IBM Software Support with three screen captures of the Performance tab, waiting 30 seconds between each screen capture.
  • On what type of system is Classification Module running, for example, production, development, test or QA, or staging?
  • Were there any recent changes to the system?
  • Are there any other products or software running on the same computer besides Classification Module and its prerequisite products?
  • If you run Classification Module in conjunction with IBM Content Collector, FileNet P8, IBM Enterprise Records (formerly FileNet Records Manager), or IBM Content Manager, answer the following questions for each product with which you integrate:
    - Which version of the other product do you use?

    - Is Classification Module running on the same computer as the other product?

    - On how many servers is the other product installed?

    - Do you use the Classification Module Classification Center with the other product?


Required logs and files
Run the Trace Monitor tool and collect the logs before you call IBM Software Support.

Restriction: The Trace Monitor tool is available only on Windows. If you run Classification Module on an AIX, Linux, or Solaris system, you can run Trace Monitor from a Windows computer and configure it to monitor the Classification Module server by using the remote option explained below. To run Trace Monitor on the Windows computer, install the Classification Module server or contact IBM Software Support to obtain the required Trace Monitor executable and .dll files.

The Trace Monitor tool connects to a service on the Classification Module server that collects information. On Windows, this service is installed as a Windows service and starts automatically. However, on AIX, Linux, and Solaris platforms, this service needs to be started manually by running the bnsRun trace command.
  1. Locate the Classification Module installation directory and find the bin subdirectory.
  2. From the bin directory, run the TraceMonitor.exe file.
  3. Open a connection to a local or remote computer.
    1. If you run Trace Monitor on the computer that hosts Classification Module, click File > Open > Local Connection.
    2. If you run Trace Monitor on a remote computer, click File > Open > Remote Connection and specify the name or IP address of the computer on which Classification Module runs.
  4. Turn on Debug Filtering:
    1. Click the Filter icon:
    2. Right-click the debug icon () and select Accept all subsystems.
    3. Click OK to close the filter window.
  5. Start logging the messages:
    1. Click Log > Monitor Logging > Start Logging.
    2. Specify the location and name for the log file and click OK.
  6. Now run through the problem scenario to record any error messages.
  7. To stop logging the messages so that the log file is closed, click Log > Monitor Logging > Stop Logging.
  8. Send the log file to IBM Software Support.

In addition to the Trace Monitor logs, gather saved analysis data from the Classification Module Management Console. This XML file can then be sent to IBM Software Support for further analysis. Click the following link for instructions on gathering this data:
http://publib.boulder.ibm.com/infocenter/classify/v8r7/topic/com.ibm.classify.admin.doc/t_AG_Convert_Event_XML.htm


If documents are not being classified as you expected, or do not contain the expected metadata, perform the following steps to gather the appropriate debugging information:

Restriction: The following procedure is applicable only if you run IBM Classification Module 8.7 Fix Pack 1 or later.

To gather the debugging information on Windows:
  1. Stop the Classification Module server. Open the Windows Services console and stop the IBM InfoSphere Classification Module Process Manager service.
  2. On the computer that hosts the Classification Module server, create a system variable with the name ICM_DEBUG_FOLDER. To set the variable, open the System Properties window, click the Advanced tab, and click Environment Variables. Ensure that you create the variable in the System variables list. For the value of the variable, specify the absolute path to an existing directory into which debug information will be generated. For example, specify C:\debug_info.
  3. Start the Classification Module server by restarting the IBM InfoSphere Classification Module Process Manager service.
  4. Run classification on the documents that are not being classified as you expected. When requests are sent to the server, files containing debug information are created in the defined debug folder.
  5. After the documents are classified, turn off debug mode. Delete the ICM_DEBUG_FOLDER variable and restart the Classification Module server.
    Important: This variable should be used sparingly and not left defined because many files are created in the debug folder and can quickly fill up a large amount of disk space.
  6. Send all the files in the debug folder to IBM Software Support.

To gather the debugging information on AIX, Linux, or Solaris:
  1. Stop the Classification Module server by running the bnsRun stop command.
  2. On the computer that hosts the Classification Module server, use the export command to set a variable with the name ICM_DEBUG_FOLDER. For the value of the variable, specify the absolute path to an existing directory into which debug information will be generated. For example, enter the following command: 
    export ICM_DEBUG_FOLDER=/data/users/me/debug_info
  3. Start the Classification Module server by running the bnsRun start command. Ensure that you run this command in the same shell in which you exported the ICM_DEBUG_FOLDER variable.
  4. Run classification on the documents that are not being classified as you expected. When requests are sent to the server, files containing debug information are created in the defined debug folder.
  5. After the documents are classified, turn off debug mode:
    1. Delete the ICM_DEBUG_FOLDER variable by running the following command:
      unset ICM_DEBUG_FOLDER
    2. Restart the Classification Module server.
      Important: This variable should be used sparingly and not left defined because many files are created in the debug folder and can quickly fill up a large amount of disk space.
  6. Send all files in the debug folder to IBM Software Support.


Classification Center logs and files
If you experience a problem while you run the Classification Center application, perform the following steps to run the application in verbose mode and gather the logs and configuration files. In application-level verbose mode, the Classification Center application adds summary information about the classification process (such as start time, number of documents classified, total number of errors, total number of skipped documents, and elapsed time) in the classificationCenter.log file.
  1. In the classificationCenter.properties file, set the value of the applicationVerbose property to true. By default, your Classification Center configuration profile is saved in one of the following directories under the ICM_home\ECMTools\conf directory depending on your repository type:
    • ContentManager
    • FileNetP8
    • FileSystem
  2. Restart the Classification Center server and log into the Classification Center web application.
  3. Verify that the specified criteria about the documents to classify or review is correct, and click Save to record the criteria to the log file.
    • To verify the documents to classify criteria, click the Configuration tab, click Content to Classify, and click Edit Content to Classify.
    • To verify the documents to review criteria, click the Review tab, click Content to Review, and click Edit Content to Review.
  4. Repeat the problem scenario.
  5. Send all files in the following directories to IBM Software Support:
    • ICM_home\ECMTools\logs
    • ICM_home\ECMTools\conf\Repository_type (for example, ICM_home\ECMTools\conf\ContentManager)
      If you classify file system content, also send the ICM_home\ECMTools\conf\FileSystem\md directory.
  6. To disable verbose mode, change the value of the applicationVerbose property to false and restart the Classification Center server.

In some cases, IBM Software Support might require additional information and request that you run the Classification Center application in document-level verbose mode. In such a case you perform the previous steps, but in addition to setting the value of the applicationVerbose property to true, also set the value of the documentVerbose property to true. In document-level verbose mode, the Classification Center application adds information to the classificationCenter.log file about each document that is processed.

In some cases, IBM Software Support might also request that you perform the following steps to include detailed debugging information in the classificationCenter.log file.
  1. Edit the ICM_home\ECMTools\ClassificationCenter\WebContent\WEB-INF\classes\log4j.properties file.
    1. Change the values of the following MaxFileSize parameters from 1MB to 15MB:
      • log4j.appender.F1.MaxFileSize
      • log4j.appender.VerboseLogging.MaxFileSize
      • log4j.appender.F2.MaxFileSize
    2. Comment out the following line:
      log4j.rootLogger=ERROR,F1
      • Add the following lines after the commented-out #log4j.rootLogger=ERROR,F1 line:
      • log4j.logger.com.ibm.classification = DEBUG,F1
      • log4j.logger.org =ERROR,F1
      • log4j.logger.com.ibm.mm.sdk = ERROR,F1
  2. Restart the Classification Center server and log into the Classification Center web application.
  3. Repeat the problem scenario.
  4. Send all files in the ICM_home\ECMTools\logs directory to IBM Software Support.
  5. To return to the default logging mode, undo your changes to the log4j.properties file:
    1. Change the values of the following MaxFileSize parameters from 15MB to 1MB:
      • log4j.appender.F1.MaxFileSize
      • log4j.appender.VerboseLogging.MaxFileSize
      • log4j.appender.F2.MaxFileSize
    2. Uncomment the following line:
      log4j.rootLogger=ERROR,F1
    3. Delete the following lines:
      • log4j.logger.com.ibm.classification = DEBUG,F1
      • log4j.logger.org =ERROR,F1
      • log4j.logger.com.ibm.mm.sdk = ERROR,F1


Additional logs and files
In some cases, IBM Software Support might request that you gather additional information.

IBM Software Support might request that you perform the following steps to gather temporary binary files that are generated during the text extraction process. These steps are applicable only if you run IBM Classification Module 8.7 or later.

To gather the temporary binary files on Windows:
  1. Stop the Classification Module server. Open the Windows Services console and stop the IBM InfoSphere Classification Module Process Manager service.
  2. On the computer that hosts the Classification Module server, create a system variable with the name SPAWN_DEBUG and specify 1 as its value. To set the variable, open the System Properties window, click the Advanced tab, and click Environment Variables. Ensure that you create the variable in the System variables list.
  3. Start the Classification Module server by restarting the IBM InfoSphere Classification Module Process Manager service.
  4. Run classification on your documents.
  5. After the documents are classified, turn off debug mode. Delete the SPAWN_DEBUG variable and restart the Classification Module server.
    Important: This variable should be used sparingly and not left defined because many binary files are generated and can quickly fill up a large amount of disk space.
  6. Send all the files in the ICM_home\working_tmp directory to IBM Software Support.

To gather the temporary binary files on AIX, Linux, or Solaris:
  1. Stop the Classification Module server by running the bnsRun stop command.
  2. On the computer that hosts the Classification Module server, enter the following command:
    export SPAWN_DEBUG=1
  3. Start the Classification Module server by running the bnsRun start command. Ensure that you run this command in the same shell in which you exported the SPAWN_DEBUG variable.
  4. Run classification on your documents.
  5. After the documents are classified, turn off debug mode:
    1. Delete the SPAWN_DEBUG variable by running the command unset SPAWN_DEBUG
    2. Restart the Classification Module server.
      Important: This variable should be used sparingly and not left defined because many binary files are generated and can quickly fill up a large amount of disk space.
  6. Send all the files in the ICM_home/working_tmp directory to IBM Software Support.


In some cases, IBM Software Support might request that you perform the following steps to capture all requests and responses that are sent between the Classification Module client and server. These steps are applicable only if you run IBM Classification Module 8.7 Fix Pack 1 or later.
  1. In the Management Console, click File > Edit Global Properties and select the Enable debug mode check box.
  2. Repeat the problem scenario to capture the requests and responses between the client and server.
  3. After you capture the required debugging information, clear the Enable debug mode check box.
    Important: Because IBM InfoSphere Classification Module captures and stores large amounts of data when running in debug mode, enabling this option might have a significant impact on server performance. In addition, the generated files can quickly fill up a large amount of disk space. Ensure that you disable this option as soon as possible after you capture the required debugging information.
    Tip: You can also disable debug mode by restarting the Classification Module server.
  4. Send all the .log files in the ICM_home\working_tmp directory to IBM Software Support.


Sending files to IBM Software Support
Upload files to IBM Software Support at: http://www.ecurep.ibm.com/app/upload

Related information

Uploading files to IBM Support
Content Classification System Requirements
Preparing saved analysis data (for version 8.7)
Extracting content from FileNet P8 (for version 8.7)

Rate this page:

(0 users)Average rating

Document information


More support for:

Content Classification

Software version:

8.5, 8.6, 8.7, 8.8

Operating system(s):

AIX, Linux, Solaris, Windows

Reference #:

1417244

Modified date:

2013-02-03

Translate my page

Machine Translation

Content navigation