Installation of AEM and Eaton 6.2.1 and 6.2.1 IF01 agents fails on xLinux

Technote (troubleshooting)


IBM Tivoli Monitoring for Energy Management 6.2.1 and 6.2.1 Interim Feature 01 AEM and Eaton agents fail to install successfully on xLinux.


You will see the following error message when installing:

"Preparing to install the IBM Global Security Kit (GSkit)
error: open of /opt/IBM/ITM/gskit/li6243/gsk7bas-7.0-3.18.i386.rpm failed: No such file or directory error: KCI1166E Prerequisite IBM GSkit failed to install. Retry after the problem has been corrected in your environment."

The problem will not be seen if some other IBM Tivoli Monitoring component (ex. Monitoring Agent for Linux OS) is already installed because it will have installed this prerequisite.


The error occurs because the GSkit package gsk7bas-7.0-3.18.i386.rpm is not included in the install image.

Resolving the problem

1) manually install the GSkit RPM before installing the Eaton or AEM agents.
2) install another ITM component, ex. Linux OS agent, which installs this RPM prereq.

Product Alias/Synonym

AEM agent
Eaton agent

Document information

More support for:

Tivoli Monitoring for Energy Management

Software version:


Operating system(s):


Reference #:


Modified date:


Translate my page

Content navigation