IBM Support

Publish operation fails when uploading an archive to the server

Troubleshooting


Problem

Publish changes to an installed application fails when uploading an archive to the server due to hostname verification problem.

Symptom

The following error message is received in an error dialog and can also be found in the workspace .log file:

!MESSAGE Failure uploading archive to server

Cause

The hostname verification fails when a server security certificate is configured with an IP address rather than a hostname.

Resolving The Problem

To resolve this problem, ensure that the hostname verification is disabled. To do this, edit the config.ini file (<wid_install_root>/configuration/config.ini) and delete the following line:

com.ibm.ssl.performURLHostNameVerification=true

Save the file and relaunch WebSphere Integration Developer.

[{"Product":{"code":"SSQQFK","label":"WebSphere Integration Developer"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Test and deployment tools","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"7.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
23 June 2018

UID

swg21414552