IBM Support

Database-transfer to DB2/zOS fails on FEEDBACK domain with SQLCODE: -904, SQLSTATE: 57011, SQLERRMC: 00C900A3

Troubleshooting


Problem

When executing the WebSphere Portal ConfigEngine script 'database-transfer' to transfer the Portal data from Derby to DB2/zOS, it may fail at the Feedback database domain with DB2 exceptions SQLCODE: -904, SQLSTATE: 57011, SQLERRMC: 00C900A3

Symptom

In the ConfigTrace.log, the full exception will be:

====================================
action-populate-feedback-database:
     [echo] DbDomain = feedback
     [echo] FbkDbType = db2_zos


  [sqlproc] action: execute-sql-scripts
  [sqlproc] _________________________________________________________
  [sqlproc] DbDomain: feedback
  [sqlproc] Database autocommit parameter false
  [sqlproc] Reading file /opt/IBM/WebSphere/wp_profile/ConfigEngine/config/work/pzn/db2_zos/fbk_Data.sql
  [sqlproc] Connected to jdbc:db2://mydb2zos.server.com:50000/fdbkdb
  [sqlproc] Setting database autocommit to:false
  [sqlproc] INSERT INTO feedback.LOGCONTROL (LogState, ReportServer, ReportSSL) VALUES
  [sqlproc]    (0, 'localhost', 0)

  [sqlproc] Error during statement execution!
  [sqlproc] com.ibm.db2.jcc.a.SqlException: DB2 SQL error: SQLCODE: -904, SQLSTATE: 57011, SQLERRMC: 00C900A3;00000200;FDBKDB.FBTBSPCE
  [sqlproc] at com.ibm.db2.jcc.a.tf.d(tf.java:1397)
  [sqlproc] at com.ibm.db2.jcc.b.jb.l(jb.java:367)
  [sqlproc] at com.ibm.db2.jcc.b.jb.a(jb.java:64)
====================================

Cause

The exception froms from the DB2/zOS system:

SQLCODE: -904, SQLSTATE: 57011, SQLERRMC: 00C900A3;00000200;FDBKDB.FBTBSPCE

It essentially means that the Tablespace mentioned in the SQLERRMC portion of the exception (in this case FDBKDB.FBTBSPCE) is in "check pending" state and unable to process requests.

Normally, the database administrator can run "CHECK DATA" against the failing tablespace, but in this case CHECK DATA does not resolve the issue. The feedback transfer merely puts the tablespace back into 'check pending' status.

This issue was ultimately caused by a corrupt tablespace.

Resolving The Problem

To resolve this problem, drop and recreate the faulty tablespace. Once that is done, re-execute the database-transfer.

[{"Product":{"code":"SSHRKX","label":"WebSphere Portal"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Installation \u0026 Configuration","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"6.1","Edition":"Enable;Extend","Line of Business":{"code":"LOB31","label":"WCE Watson Marketing and Commerce"}}]

Document Information

Modified date:
03 December 2021

UID

swg21413739