IBM Support

DataStage Designer: Stage does not open

Troubleshooting


Problem

When user opens stage properties on the Designer canvas, either by double-clicking a stage or selecting "properties" in the context menu, the user will see an hourglass icon, but does not see the properties dialog nor regain control of client session.

Cause

An entry in the Windows Registry has been damaged resulting in the properties dialog having an invalid starting location on screen. As a result the properties dialog is open but not visible.

Resolving The Problem

To confirm if the failing client has properties dialog invalidly displayed off-screen, hit the escape (ESC) key and see if the user regains control of the DataStage Designer client. If so, then use the following steps to correct this problem on the failing machine:

  1. Close all DataStage clients.
  2. Select Start->Run on the Windows taskbar and then enter command "regedit".
  3. In the Registry editor, Remove the 2 folders related to Designer client settings. Note that the folder names will depend upon which release of DataStage or Information Server you are using.

    For versions 7.5.x, 8.0.1, and 8.1, remove the following 2 registry key folders:
    HKEY_CURRENT_USER\Software\Ascential Software\DSDesign
    HKEY_CURRENT_USER\Software\Ascential Software\DataStage Client\Designer

    For Information Server 8.5, 8.7, or 9.1, the folder names are:
    HKEY_CURRENT_USER\Software\IBM\InformationServer\DataStage Client\***\DSDesign
    HKEY_CURRENT_USER\Software\IBM\InformationServer\DataStage Client\***\DataStage Client\Designer

    where *** is replaced with a long client id such as 5edeb69c-3ea5-409d-bca5-f0853cfd3ff6. For example:
    HKEY_CURRENT_USER\Software\IBM\InformationServer\DataStage Client\5edeb69c-3ea5-409d-bca5-f0853cfd3ff6\DSDesign
    HKEY_CURRENT_USER\Software\IBM\InformationServer\DataStage Client\5edeb69c-3ea5-409d-bca5-f0853cfd3ff6\DataStage Client\Designer

    Note that if you have installed multiple DataStage client releases onto one machine, you may have multiple client ids listed under key:
    HKEY_CURRENT_USER\Software\IBM\InformationServer\DataStage Client

    In that situation, you only want to remove the Designer settings for the specific release of DataStage client that is having the problem. To determine which client id is associated with which DataStage Client release, look in the InformationServer directory associated with the DataStage client release which has the problem, for example:
    C:\IBM\IS870\InformationServer. The actual location will vary since the user installing multiple releases must choose a unique directory for each. Within the InformationServer directory is a file called Version.xml which will show the version of DataStage client installed, and then list your client id following the label "clientTagId", for example:
    clientTagId="5edeb69c-3ea5-409d-bca5-f0853cfd3ff6
  4. Exit the Registry editor
  5. Re-try failing scenario and confirm the problem no longer occurs.

[{"Product":{"code":"SSVSEF","label":"IBM InfoSphere DataStage"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.1;8.0;7.5","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
23 June 2018

UID

swg21413718