Question & Answer
Question
How do you prevent file deletion errors when installing, upgrading, rolling back, or uninstalling an IBM Rational Team product?
Cause
During an install, upgrade, rollback, or uninstall operation for an IBM Rational Team product, IBM Installation Manager checks for running processes.
If the running processes are using files located in the installation directory, Installation Manager blocks the install, upgrade, rollback, or uninstall operation.
You see a warning message telling you to stop running processes so that the operation can continue. In some cases, Installation Manager cannot detect that a file is in use.
As a result, the installation, upgrade, rollback, or uninstallation fails because one of the files to be deleted is still in use.
Answer
Preventive Steps
To prevent failures during install, upgrade, rollback, and uninstall operations for IBM Rational Team products, confirm that no files are in use before starting the operation.
- On Windows Server machines, disable terminal services.
Terminal services allow you to establish multiple sessions on the same machine. Multiple sessions make it difficult to verify that all conflicting processes are stopped and remain stopped. Instructions for disabling these services are provided in Technote #1407537 Disable Terminal Services prior to updating, rolling back, modifying, or uninstalling an Rational Team Product via Installation Manager. - Close all running Graphical User Interface (GUI) applications.
These applications include Operating System Management applications such as the Service Control Manager and Event Viewer. Installation Manager must be the only running application. Closing the GUI applications ensures that no resource files are loaded when you start Installation Manager and perform the install, upgrade, rollback, or uninstall operation.
WORKAROUND:
If you receive a file deletion error after an install, upgrade, rollback or uninstall operation starts, use the Process Explorer utility from SysInternal to determine which process is locking the file. For each file that Installation Manager could not delete, take the following steps to remove the operating system lock.
- Download Process Explorer from http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx.
- Uncompress Process Explorer onto the machine.
- Run
procexp.exe
. - After the Process Explorer opens, click Find > Find Handle or DLL.
- Type the name of the file that Installation Manager could not delete and click Search.
Note: You do not need to enter the file path. - Process Explorer displays the process and process ID of processes that are currently locking the file.
Note: The process ID is listed in the PID column. - Use Task Manager to stop any processes that are locking files and preventing them from being removed during a product installation or update operation.
- In the Start Menu for Windows, click Run. Then, type
taskmgr.exe
and press Enter to open the Task Manager. - Click the Processes tab.
- To display process IDs for the running processes, click View > Select Columns from the Task Manager menu. Then, select PID (Process Identifier) and click OK.
- Click the PID column header to sort the processes by Process ID.
- Locate the process ID that is using the file. Then, right-click on the process name and click End Process.
- In the Start Menu for Windows, click Run. Then, type
- Repeat steps 5 - 8 for each file that is preventing the install, rollback, update, or uninstall operation.
- Close Task Manager and Process Explorer
After terminating all conflicting processes, start Installation Manager and perform the install, upgrade, rollback, or uninstall operation again.
If the error still occurs after following the preventive steps or work around, reboot the computer, and delete the files that Installation Manager could not delete.
Related Information
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Document Information
Modified date:
30 November 2020
UID
swg21412312