Rational License server versions and the corresponding FLEXnet versions

Technote (FAQ)


Question

What are the underlying FLEXnet versions for the various versions of IBM Rational License Servers?

Cause

You want to know the compatible FLEXnet version while using Rational products which uses legacy vendor daemon versions.

Answer

Telelogic License server versions and their corresponding FLEXnet version are as follows:

Rational License server versions and their corresponding FLEXnet version are as follows:

Rational License Server Version
FLEXnet Versions
Vendor Daemon version
7.0
10.8
rational daemon v10.8
7.0.1
11.3
rational daemon v11.3

ibmratl daemon v11.3

7.1
11.5.0.6
rational daemon v11.5

ibmratl daemon v11.5

8.0
11.6.0.0
rational daemon v11.6

ibmratl daemon v11.6

8.1.1
11.8.0
ibmratl daemon v11.8
8.1.1 iFix 06
11.10
ibmratl daemon v11.10
8.1.2
11.8.0
ibmratl daemon v11.8
8.1.2 iFix 02
11.10
ibmratl daemon v11.10
8.1.3.x
11.10
ibmratl daemon v11.10
8.1.4.x
11.10
ibmratl daemon v11.10

Note for Rational License Server version greater or equal to v8.1.1

Starting from this version of license server v8.1.1 the ‘telelogic’ daemon file binary is merged with the’ ibmratl’ daemon along with ‘rational’ daemon which enables the license server to host all products served by both these daemons. This also provides backward compatibility to older legacy versions for both rational and telelogic products

To summarize, if v8.1.1 is used as the license server , it can just have single VENDOR/DAEMON* line in the license files with just VENDOR ibmratl , it can serve licenses for both rational and telelogic products.


A SERVER license can have the following initial lines:
---------------------
SERVER <hostname> <hostid> <port number>
VENDOR ibmratl
---------------------

*VENDOR and DAEMON are complementary keywords hence can be used interchangeably with the latest version. Hence the following is also valid
---------------------
SERVER <hostname> <hostid> <port number>
DAEMON ibmratl
---------------------

Inclusion of Flexnet v11.10 is due to the security issues as discussed in the following technotes:

http://www.ibm.com/support/docview.wss?uid=swg21573825
http://www.ibm.com/support/docview.wss?uid=swg21579415

Related information

Flexera Software
A Japanese translation is available
A simplified Chinese translation is available

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Rational License Key Server
FLEXlm

Software version:

2.0, 7.0.1, 7.1, 8.0, 8.1.1, 8.1.1.6, 8.1.2, 8.1.2.2, 8.1.3, 8.1.3.3, 8.1.4, 8.1.4.1, 8.1.4.2

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Reference #:

1411515

Modified date:

2014-05-14

Translate my page

Machine Translation

Content navigation