Troubleshooting
Problem
After upgrading IBM Rational ClearCase from 7.1.0.x to a later version on Linux or UNIX systems, the ClearCase Remote Client (CCRC) views cannot be be accessed using the ClearCase Remote Client
Symptom
You create a view or check out a file from an existing view and receive a permission denied error.
Examples of permission denied errors.
Creating a view
CRVAP0087E (conflict): CCRC command 'mkview' failed: Unable to create a view at "/var/adm/rational/clearcase/ccweb/user.mycompany.com/st1_1244562355562": error detected by ClearCase subsystem
ClearCase CM Server: Error: Unable to create directory "/var/adm/rational/clearcase/ccweb/user.mycompany.com/st1_1244562355562":
Permission denied.
ClearCase CM Server: Error: Unable to create snapshot view "/var/adm/rational/clearcase/ccweb/user.mycompany.com/st1_1244562355562".
CRVAP0087E (conflict): CCRC command 'mkview' failed: Unable to create a view at "/var/adm/rational/clearcase/ccweb/user.mycompany.com/st1_1244562355562": error detected by ClearCase subsystem
ClearCase CM Server: Error: Unable to create directory "/var/adm/rational/clearcase/ccweb/user.mycompany.com/st1_1244562355562": Permission denied.
ClearCase CM Server: Error: Unable to create snapshot view "/var/adm/rational/clearcase/ccweb/user.mycompany.com/st1_1244562355562".
Checking out a file
CRVAP0087E CCRC command 'checkout' failed: Unable to checkout "/var/adm/rational/clearcase/ccweb/user.mycompany.com/user_view_2/tmp/user_vob/testdir/file1.txt"
Problems performing checkout.
ClearCase CM Server: Error: No permission to perform operation "checkout".
ClearCase CM Server: Error: Must be one of: member of element group, element owner, VOB owner, root
ClearCase CM Server: Error: Unable to check out "/var/adm/rational/clearcase/ccweb/user.mycompany.com/user_view_2/tmp/user_vob/testdir/file1.txt".
Cause
During the installation of Rational ClearCase, you are asked for a temporary directory to use during the installation to unzip large artifacts. This temporary directory is used to preserve user configuration settings during an update or uninstall process. If you specify a directory that is mounted on a file system that is separate from the installation directory, the file permissions and owners are not preserved when the files are moved across the file systems.
Resolving The Problem
This issue has been addressed in 7.1.1.1 version of ClearCase.
Before you update the product, take the following steps:
- Change directory to
/opt/rational/common/CM/scripts
- Execute commands to determine the ccweb view storage directory:
/opt/rational/common/CM/profiles/cmprofile/bin/wsadmin.sh
wsadmin>source teamAdminUtils.jacl
wsadmin>set t [getTeamServer]
wsadmin>$AdminControl getAttribute $t ccrcViewStorage
wsadmin> quit
Example of command output:
# /opt/IBM/RationalSDLC/common/CM/profiles/cmprofile/bin/wsadmin.sh
WASX7209I: Connected to process "server1" on node dfltNode using SOAP connector; The type of process is: UnManagedProcess
WASX7029I: For help, enter: "$Help help"
wsadmin>source teamAdminUtils.jacl
wsadmin>set t [getTeamServer]
WebSphere:cell=dfltCell,version=6.1.0.25,spec=1.0,name=TeamServerMBeanId,mbeanIdentifier=TeamServerMBeanId,type=stp.management.TeamServerMBean,node=dfltNode,process=server1
wsadmin>$AdminControl getAttribute $t ccrcViewStorage
/var/ccweb
wsadmin> quit
- Execute
tar -cvf <tar_file> ccweb_directory
whereccweb_directory
is/var/ccweb
. This command creates a tar file of the ccweb view storage directory. - Continue with the upgrade.
- After the upgrade completes, execute
tar -xvf tar_file
to restore the original ccweb view storage directory.
To resolve this issue after you have updated the product, take the following steps:
- Change directory to
/opt/rational/common/CM/scripts
- Execute commands to determine the ccweb view storage directory:
/opt/rational/common/CM/profiles/cmprofile/bin/wsadmin.sh
wsadmin>source teamAdminUtils.jacl
wsadmin>set t [getTeamServer]
wsadmin>$AdminControl getAttribute $t ccrcViewStorage
wsadmin> quit
Example of command output:
# /opt/IBM/RationalSDLC/common/CM/profiles/cmprofile/bin/wsadmin.sh
WASX7209I: Connected to process "server1" on node dfltNode using SOAP connector; The type of process is: UnManagedProcess
WASX7029I: For help, enter: "$Help help"
wsadmin>source teamAdminUtils.jacl
wsadmin>set t [getTeamServer]
WebSphere:cell=dfltCell,version=6.1.0.25,spec=1.0,name=TeamServerMBeanId,mbeanIdentifier=TeamServerMBeanId,type=stp.management.TeamServerMBean,node=dfltNode,process=server1
wsadmin>$AdminControl getAttribute $t ccrcViewStorage
/var/ccweb
wsadmin> quit
- Execute
cleartool lsview | grep ccweb_directory | grep machine_name > /var/tmp/ccweb_views
. This command determines every view that exists on the current registry server in the ccweb_directory.
Example of command output:
# /opt/rational/clearcase/bin/cleartool lsview | grep /var/adm/rational/clearcase/ccweb | grep mymachine
user_view mymachine:/var/adm/rational/clearcase/ccweb/user/user_view/.view.stg
- Correct the permissions on each view returned by executing:
/opt/rational/clearcase/etc/utils/fix_prot -force -root -recurse -chown user_name -chgrp group_name -chmod 755 view-storage-path
where:
user_name
- the user name for the owner of the view ("user" in the above example)
group_name
] - the default group name for the owner of the view. To determine this value, execute [id user_name
on the terminal. If the user is using a different primary group, then the administrator should follow up with the user to determine that group.view-storage-path
- the view storage path for the view ("/var/adm/rational/clearcase/ccweb/user/user_view/.view.stg" in the above example)
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Document Information
Modified date:
23 June 2018
UID
swg21411191