Troubleshooting
Problem
During a DB2 backup via API to the Tivoli Storage Manager the backup fails with a reason code of 157.
Cause
Ncipher timeout is too short
Diagnosing The Problem
DB2diag.log shows:
2009-10-06-03.28.18.898537-240 I1988533A377 LEVEL: Error
PID : 307692 TID : 38395 PROC : db2sysc 28
INSTANCE: udbcdwp NODE : 028
EDUID : 38395 EDUNAME: db2med.5079.0 (CDWPDB) 28
FUNCTION: DB2 UDB, database utilities, sqluMapVend2MediaRCWithLog, probe:686
MESSAGE : Error in vendor support code at line: 1338 rc: 157
...
2009-10-06-03.28.19.931065-240 E1989259A379 LEVEL: Error
PID : 307692 TID : 38395 PROC : db2sysc 28
INSTANCE: udbcdwp NODE : 028
EDUID : 38395 EDUNAME: db2med.5079.0 (CDWPDB) 28
FUNCTION: DB2 UDB, database utilities, sqluMCWriteToDevice, probe:909
MESSAGE : Media controller -- problem during writing to vendor device
...
MESSAGE : SQL2033N An error occurred while accessing TSM during the processing
of a database utility. TSM reason code: "".
The DB2 API RC 157 means:
- 0157 S DSM_RC_WILL_ABORT The transaction will be aborted.
AIX errpt shows a tape error:
- LABEL: TAPE_ERR2
IDENTIFIER: 476B351D
.
Date/Time: Tue Oct 6 16:58:11 EDT 2009
...
Resource Name: rmt6
Resource Class: tape
Resource Type: 3580
...
Description
TAPE DRIVE FAILURE
...
Detail Data
SENSE DATA
0600 0000 0A00 0400 0000 0000 0000 0000 0102 0000 7000 0B00 0000 000C 0000 0000
0400 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
- Debug information:
Oct 11 05:41:53 HE1TSM2E1 kernel: nscgw4 tape I/O error: result 20000, <--------
sense key 0, asc 0, ascq 0
Oct 11 05:41:53 HE1TSM2E1 kernel: gwdp->cur_sessid = 0
Oct 11 05:41:53 HE1TSM2E1 kernel: cdbs: 0x0a 0x00 0x02 0x5d 0xd0 0x00
The 20000 result indicates the drive is busy and not responsive.
Note:
1)The drive dump is reporting the sense data from ncipher devices as the sense is 0's - no problem.
2) The Tivoli Storage Manager activity log is reporting different sense data:
- 10/06/09 16:58:11 ANR8302E I/O error on drive RMT6_260 (/dev/rmt6) with
volume 568571 (OP=WRITE, Error Number=5, CC=0, KEY=0B,
ASC=04, ASCQ=00, SENSE=70.00.0B.00.00.00.00.0C.00.00.00.-
00.04.00.00.00.00.00.00.00, Description=An undetermined
error has occurred). Refer to Appendix C in the
'Messages' manual for recommended action. (SESSION:
69057, PROCESS: 1180)
Resolving The Problem
It was determined the Ncipher device timeout was less than the recommended scsi timeout of 900 seconds for the device. Increasing the timeout resolved the issue in this case.
[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Supported Versions","Edition":"Edition Independent","Line of Business":{"code":"LOB26","label":"Storage"}}]
Product Synonym
TSM ITSM ADSM IBM Spectrum Protect
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Document Information
Modified date:
23 June 2018
UID
swg21411186