IBM Support

CNC-DS-0015 Error extracting options error with scheduled e-mails with attachments

Troubleshooting


Problem

If customer has a trigger or a scheduled job set to send out many e-mails with attachments all at once, you could possibly run into the following error. CNC-DS- 0015 Error extracting options

Symptom

Many e-mails with attachments being sent all at once

Cause

Delivery service is hitting its timeout of 7 seconds

Resolving The Problem

This issue can be resolved by going increasing the tuning settings for the following from 4 to 10.

Maximum connections for delivery service during non-peak period

Maximum number of delivery service connections during peak period

Also there is an Advanced setting for the Delivery Service that can be set to increase the default timeout,which is 7 (seconds) (as of 10.2.0 the default is 120)

Parameter = primary.wait.dls

Value = 240

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Install and Config","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"10.2.2;10.2.1;10.2;10.1.1;10.1;8.4.1","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
23 June 2018

UID

swg21408737