Detailed system requirements for IBM Lotus Connector for SAP Solution 2.0

Technote (FAQ)


Question

What are the detailed system requirements for IBM Lotus Connector for SAP Solution 2.0?

Answer

Prerequisites:

The IBM Lotus Connector for SAP Solutions uses libraries and .dll files found in SAP's Remote Function Call Software Development Kit (RFCSDK). These files are available from several locations at the online SAP Software Distribution Center section of the SAP Support Portal.

To access, do the following:

1. Click Downloads --> SAP Software Distribution Center.

2. Select Support Packages and Patches.

3. Select Entry by Application Group.

4. Select Additional Components.

5. To download RFCSDK kits for non-Unicode or Unicode, choose SAP RFC SDK or SAP RFC SDK UNICODE.

6. Search for RFCSDK (look for RFCSDK 6.40).

    NOTE: The RDCSDK kits are different for each of the following: 32-bit non-Unicode Connector for SAP Solutions, 32-bit Unicode for Connector for SAP Solutions, 64-bit non-Unicode Connector for SAP Solutions, 64-bit Unicode Connector for SAP Solutions.

7. Obtain the following files, listed below by platform:
  • 32-bit IBM Lotus Connector for SAP Solutions non-Unicode connector for Windows:
    -- The files will be available with 32-bit non-Unicode RFCSDK 6.40 kit for W32.
    -- Copy the librfc32.dll file to the <WINDOWS>\SYSTEM32 directory.
  • 32-bit IBM Lotus Connector for SAP Solutions Unicode connector for Windows:
    -- The files will be available with 32-bit Unicode RFCSDK 6.40 kit for W32.
    -- Copy the following files to the <WINDOWS>\SYSTEM32 directory:
        librfc32u.dll
        icudt*.dll
        icuin*.dll
        icuuc*.dll
        libsapucum.dll

        NOTE: The "icu*.dll" files are the International Component for Unicode (ICU) libraries required by the librfc32u.dll file.
  • 64-bit IBM Lotus Connector for SAP Solutions non-Unicode connector for Windows:
    -- The files will be available with 64-bit non-Unicode RFCSDK 6.40 kit for W64.
    -- Copy the librfc32.dll file to the System directory.
  • 64-bit IBM Lotus Connector for SAP Solutions Unicode connector for Windows:
    -- The files will be available with 64-bit Unicode RFCSDK 6.40 kit for W64.
    -- Copy the following files to the System directory:
        librfc32u.dll
        icudt*.dll
        icuin*.dll
        icuuc*.dll
        libsapucum.dll

        NOTE: The "icu*.dll" files are the International Component for Unicode (ICU) libraries required by the librfc32u.dll file.

NOTE: A full SAPGUI client is only required when using Lotus Domino Access to SAP Business Workflow. In that scenario, the SAPGUI must be installed on the Lotus Notes client but not on the Domino server.

Software requirements and considerations:
The IBM Lotus Connector for SAP Solution 2.0 is available for use with 8.x and later releases of Notes/Domino and Lotus Enterprise Integrator (LEI), and requires the following:
  • A Notes 8 or later release with the Domino 8 or later server.
  • When running LEI activities, if the LEI server on which you want the activity to run and the Domino server where the LEI Administrator resides are on separate machines, the client libraries must be installed on both machines. Refer to your LEI documentation for details.
  • If you run LEI against a remote Domino server, the Domino server must be running prior to installing the Connector.
  • The installation program uses a Temp directory as part of the installation process. If you set a Temp directory using an environment variable, be sure that the specified Temp directory exists. If not, the Installer will abort the Connector installation procedure. The drive on which the Temp directory exists must have at least 10MB of free disk space.
  • If you expect to use the Connector in conjunction with LEI, review the readme.txt file for the appropriate LEI version at the following link: https://www.ibm.com/developerWorks/lotus/documentation/lei/.
    You can also access the LC LSX (LotusScript Extension for Lotus Connector) and the DECS (Domino Enterprise Connector Service) documentation at this same site.

Supported Notes/Domino/LEI versions:

-- 32-bit version of the IBM Lotus Connector for SAP Solution 2.0 is supported on 32-bit Notes/Domino/LEI 8.x and later versions.

-- 64-bit version of the IBM Lotus Connector for SAP Solution 2.0 is supported on 64-bit Domino/LEI 8.0.1 and later versions.

Supported operating systems:
  • IBM Lotus Connector for SAP Solutions 2.0, 32-bit version (both Unicode and non-Unicode) is supported on the following platforms:
    -- Windows 2003 Server and Server Enterprise Edition 32 bit
        SAP ECC Version Support
          SAP ECC6
        Lotus Software Version Support
          Notes 8.x and later releases
          Domino 32-bit version, 8.x and later releases
          LEI 32-bit version, 8.x and later releases
          LC LSX and DECS shipped with Domino 32 bit version, 8.x and later releases
    -- Windows 2003 Server and Server Enterprise Edition 64-bit (IBM Lotus Connector for SAP Solutions is supported as a 32-bit application)
        SAP ECC Version Support
          SAP ECC6
        Lotus Software Version Support
          Domino 32-bit version, 8.x and later releases (as a 32-bit application)
          LEI 32-bit version, 8.x and later releases (as a 32-bit application)
          LC LSX and DECS shipped with Domino 32-bit version, 8.x and later releases
  • IBM Lotus Connector for SAP Solutions 64-bit version (both Unicode and non-Unicode) is supported on the following platforms:
    -- Windows 2003 Server and Server Enterprise Edition 64-bit
        SAP ECC Version Support
          SAP ECC6
        Lotus Software Version Support
          Domino 64-bit version, 8.0.1 and later releases
          LEI 64-bit version, 8.0.1 and later releases
          LC LSX and DECS shipped with Domino 64 bit version, 8.0.1 and later releases
    NOTE: For platform support information specific to your Domino/ Notes /LEI version, refer to the configuration and support documentation provided with these products. Documentation is available as follows:

Supported SAP ECC version:
The Connector for SAP Solutions 2.0 supports SAP ECC 6.


Rate this page:

(0 users)Average rating

Document information


More support for:

Lotus Connector for SAP Solutions
Connector - General

Software version:

2.0

Operating system(s):

Windows

Software edition:

Standard

Reference #:

1408617

Modified date:

2009-11-12

Translate my page

Machine Translation

Content navigation