Monitoring Agent for UNIX Logs stopped

Technote (troubleshooting)


Problem(Abstract)

The Tivoli Storage Manager reporting and monitoring feature is properly installed but the Monitoring Agent for UNIX Logs service stops shortly after being started under CandleManage.

Cause

Incomplete configuration

Diagnosing the problem

Review the log file for the UNIX Logs service. The log file name is XXX_ul_kulagent_YYY.log. The log shows the following messages:


(4AC65E7A.0006-3:logmanager.cpp,950,"getValidLogs") No valid log files found in
/opt/tivoli/tsm/reporting/itm/config/kul_configfile. Attempting to build default list from syslog file /etc/syslog.conf.
(4AC65E7A.0008-3:logmanager.cpp,986,"getValidLogs") No valid log files found in /etc/syslog.conf.
(4AC65E7A.0009-3:logmanager.cpp,663,"refresh") Agent has no work to do. Exiting...


Resolving the problem

The messages indicate that the agent has no work to do, so it is normal for the agent to stop.

The runtime environment and behaviour of the Monitoring Agent for UNIX Logs is controlled through a configuration file and environment variables. The configuration file indicates the files that the monitoring agent monitors. When the monitoring agent starts, it looks at two files to determine
which logs to monitor:

  • Customer configuration file
  • Syslog daemon configuration file

If, for any reason, the monitoring agent is unable to find at least one log to monitor from either file, it writes a message to the RAS log that contains the text, "Agent has no work to do," and then automatically
terminates.

Refer to the " IBM Tivoli Monitoring: UNIX Logs Agent User's Guide" manual for further information on configuration of the UNIX Logs service.

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Document information


More support for:

Tivoli Storage Manager
Server

Software version:

6.1

Operating system(s):

Platform Independent

Reference #:

1408035

Modified date:

2010-09-20

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