Technote (troubleshooting)
Problem
You notice Lotus Notes client startup is taking a long time when real-time scanning of Notes program directories is enabled.
Cause
In some cases, this issue is due to anti-virus software scanning the .jar files contained in the Notes/framework/ directory.
Environment
Notes 8.5.3, multi-user, Windows 7
Resolving the problem
The general recommendation for anti-virus settings is to exclude both the "notes\framework" (especially the *.jar files) and "notes\data\workspace\.config\org.eclipse.osgi" directories from scanning.
Depending on how the client was installed, it may be feasible to instead exclude the whole "notes\" directory, if Notes was installed to its default location on the OS, or exclude both "notes\" and "notes\data" separately, if custom installed. These main directories will include the sub-directories noted above.
For example, the default directories for installing Notes 8.5.3 multi-user under Windows 7 are:
| Notes programs | c:\Program Files\IBM\Lotus\Notes |
| Shared resources | c:\ProgramData\Lotus\Notes\Data |
| User data | c:\Users\<user name>\AppData\Local\Lotus\Notes\Data |
The above directories would exclude the jar file scanning, excluding jar files from real time scanning has shown significant improvements to Notes startup. Any kind of real-time scanning of the Notes program directories before startup will impact upon the performance of the client as it starts.
Related information
"Is it recommended to install Notes in multi-user mode
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