IBM Support

tacmd login failed with error message KUIC00006E

Troubleshooting


Problem

After changing the ip address or hostname of the Tivoli Enterprise Monitoring Server (TEMS) server, the tacmd login command failed with error message-KUIC00006E

Symptom

Unable to login with the tacmd command after changing the TEMS server ip address or hostname.

tacmd login -s xxx.xx.xx.xx -u sysadmin
Password:

Password?

Validating user...

KUIC00006E: The specified user name or password is incorrect.

You are not logged in because you specified an incorrect user name or password or you do not have permission to log in.

Verify the correct user name and password and that you have permission to log in.

Cause

The cause of this problem is that the KSHXHUBS member/file contains the old TEMS server ip address.
.
The KSHXHUBS member/file contains the list of hub monitoring servers with which the SOAP server communicates, and the corresponding user access list if access has been secured. The TEMS list in the KSHXHUBS member is an aliasing mechanism, equivalent to the kshxhubs.xml file on distributed platforms.

Resolving The Problem

To resolve the problem, update the old ip address with the new TEMS Server ip address in the below file/member

Windows :


%CANDLEHOME%\CMS\HTML\kshxhubs.html    

Linux/UNIX :


$candlehome/tables/$hubname/HTML/kshxhubs.xml

z/OS
 
KSHXHUBS member of RKANPARU dataset

Where $candlehome is the IBM Tivoli Monitoring installation directory and $hubname is the name of the TEMS ( CMS_NODEID)

[{"Product":{"code":"SSTFXA","label":"Tivoli Monitoring"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"ITM Tivoli Enterprise Mgmt Server V6","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
23 June 2018

UID

swg21405770