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ClearQuest fails to connect to SQL Server 2005 when the port number is not default

Troubleshooting


Problem

This technote explains how to resolve an error, "SQL Server does not exist or access denied." This can occur when using IBM Rational ClearQuest to connect to Microsoft SQL Server 2005 with a non-default port.

Symptom

If the connect options for the database in ClearQuest Designer or Maintenance Tool do not specify a PORT value for SQL Server, ClearQuest will use the default port 1433. A connection problem will occur if SQL Server is listening on a non-default port. This error will occur when connecting with either ClearQuest tool:

Unable to login to the database using the following connection information: DRIVER={SQL Server};UID=<login>;DATABASE=<database>;PWD=********;SERVER=<server>.

Verify that the information used matches the way the database was set up.
The error message was: SQLDriverConnect: RETCODE=-1, State=08001, Native Error=17
[Microsoft][ODBC SQL Server Driver][Shared Memory]SQL Server does not exist or access denied.
[Microsoft][ODBC SQL Server Driver][Shared Memory]ConnectionOpen (Connect()).

Cause

The port number listening on SQL Server 2005 is not the default port 1433. In this situation, you need to define a PORT value in the connect options for your ClearQuest databases.

Diagnosing The Problem

To verify the port that SQL Server is using:

  1. Start SQL Server Configuration Manager.
  2. Expand SQL Server 2005 Network Configuration.
  3. Double click on "Protocols for <your server name>".
  4. Select TCP/IP from protocol name list, then double click TCP/IP.
  5. From the IP Addresses tab, it displays the port SQL Server is listening on.

Resolving The Problem

If the port number is not 1433, you needs to update the connection options in Maintenance Tool or Designer, depending on whether the database is a schema repository or user database.


Here is an example:

  1. Login to the ClearQuest Maintenance Tool. Select the menu option Schema Repository > Update.
  2. Change the Connect Options to PORT=<port>.
  3. Open ClearQuest Designer.
  4. Select the menu option Databases > Update User Database Properties.
  5. Change the Connect Options to PORT=<port>.

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Document Information

Modified date:
23 June 2018

UID

swg21405143