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Failed to connect to DataStage server error on login to IBM InfoSphere DataStage

Technote (troubleshooting)


Problem(Abstract)

Error when logging into DataStage client:

Failed to connect to DataStage server: {servername}, project: {projectname}
(The connection has timed out (81015))

Cause

Error 81015 indicates the dsrpcd process timed out while waiting for response from server. This means that the client could not connect to the server process either due to overall load on the server or the listening process "dsrpcd" was hung.

Diagnosing the problem

Resolving the problem

Check the following:


  • /etc/services file for the DataStage RPC daemon entry
  • You can successfully telnet to the DataStage port (default is 31538)
  • There is no firewall blocking the connection
  • All services are running
  • If remote/vpn clients are timing out check the network. Or to work around the issue Remote Desktop in and then connect locally with the DataStage client.

If needed, refer to Diagnosing the problem to get a trace of the dsrpcd process.

Document information

More support for: InfoSphere DataStage

Software version: 7.5, 8.0.1, 8.1, 8.5

Operating system(s): AIX, HP-UX, Linux, Solaris

Reference #: 1402853

Modified date: 20 June 2017


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