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Failed to connect to DataStage server error on login to IBM InfoSphere DataStage

Troubleshooting


Problem

Error when logging into DataStage client: Failed to connect to DataStage server: {servername}, project: {projectname} (The connection has timed out (81015))

Cause

Error 81015 indicates the dsrpcd process timed out while waiting for response from server. This means that the client could not connect to the server process either due to overall load on the server or the listening process "dsrpcd" was hung.

Diagnosing The Problem

Refer to the IBM Education Assistant module on dsrpcd tracing

Resolving The Problem

Check the following:

  • /etc/services file for the DataStage RPC daemon entry
  • You can successfully telnet to the DataStage port (default is 31538)
  • There is no firewall blocking the connection
  • All services are running
  • If remote/vpn clients are timing out check the network. Or to work around the issue Remote Desktop in and then connect locally with the DataStage client.

If needed, refer to Diagnosing the problem to get a trace of the dsrpcd process.

[{"Product":{"code":"SSVSEF","label":"IBM InfoSphere DataStage"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"8.5;8.1;8.0.1;7.5","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
23 June 2018

UID

swg21402853