Technote (troubleshooting)
Problem(Abstract)
Unable to configure Tivoli Common Report (TCR) reports in ISC's Admin Center.
Symptom
The Server Name drop down menu is blank and does not contain server names that are monitored by TCR software.
Cause
The cause can be one of two things:
A. The necessary tables in the Warehous database have not been created. The historical data collection has not been configured or correctly configured to create the tables.
B. The datasource is not set up correctly. The ipaddress or username for the ITMUSER is not correct.
Environment
Windows
Diagnosing the problem
In the ISC, on the left panel, expand Tivoli Common Reporting and click on Work with Reports.
In the Navigation tab, expand Report Sets->Tivoli Products->Tivoli Storage Manager and click on Sever Reports. Right click any report and select Parameters.
The Server Name drop down menu does not show any reports.
Go to Start->All Programs->IBM DB2->DB2COPY1->General Administration->Control Center.
In the Control Center, expand All Database and Warehous. Click on Tables. Search for any tables that start with KSK (eg: KSK_DATABASE, KSK_NODE_ACTIVITY)
Resolving the problem
A. To resolve the issue, log into the Tivoli Enterprise Portal. Click Edit->Historical Configuration.
Follow the instructions to set up historical data collection exactly as specified in the manual (changes can be made later).
http://publib.boulder.ibm.com/infocenter/tsminfo/v6/topic/com.ibm.itsm.srv.install.doc/t_rpt_inst_histcfg_win.html
Note: You can change the Warehouse Interval from 1 day to 1 hour. After pressing “Configure Group” and “Start Collection for each attribute group, you should see the tables are created after 1 hour instead of 1 day.
Note: In Tivoli Enterprise Monitoring Services, it is suggested to reconfigure the Warehouse Summarization and Pruning Agent, and Warehouse Proxy to verify the correct settings as well as making sure the passwords are typed in correctly. It is suggested to retype in the passwords because there are no errors in TEMS for incorrect or mismatched passwords.
B. Open the Tivoli Enterprise Monitoring Services and right click the following services and choose reconfigure:
Monitoring Agent for Tivoli Storage Manager
Warehouse Summarization and Pruning Agent
Tivoli Enterprise Portal Server
Warehouse Proxy
For any places that prompt for a password, be sure to retype it in.
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