IBM Support

How to enable IBM Rational DOORS Database Server logging

Technote (FAQ)


Question

How do you enable IBM Rational DOORS Database logging?

Cause

None of the DOORS administration tools have a logging option.

Answer

IBM Rational DOORS logging has 6 levels; Level 1 is the most terse and 6 the most verbose. Here are the log level details:

  • Level 1: Report connections, disconnections, and problem packets.
  • Level 2: Report connections, disconnections, and packet types.
  • Level 3: As Level 2, plus packet arguments (compact format).
  • Level 4: As Level 3, but with packet arguments in verbose format.
  • Level 5: Only logs data cache operations.
  • Level 6: Logs messages as in Level 4 plus Level 5.

You may also check login_history file to check log in history under $DOORSHOME$\data\v6data\logs (example: C:\Program Files\IBM\Rational\DOORS\9.x\data\v6data\logs)

To help identify an unspecified error you can start logging at level 6 to capture all activity.

Once database logging has been enabled and you reproduce the behavior send the generated log file to Rational Client Support.


IMPORTANT: Ensure you disable database logging after the issue has been reproduced since this overhead may impact the performance.


For Microsoft Windows:

Disclaimer

This solution contains information about modifying the system registry. Before making any modifications to the Microsoft Registry Editor, it is strongly recommended that you make a backup of the existing registry. For more information describing how to back up the registry, refer to Microsoft Knowledge Base article 256986

  1. Click Start > Run > type regedit to open the registry editor on the server

  2. Navigate to the following key:

    for 32-bit Operating System:
    HKEY_LOCAL_MACHINE\SOFTWARE\Telelogic\DOORS_Server\9.x\Config

    for 64-bit Operating System:
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Telelogic\DOORS_Server\9.x\Config


  3. Create a new string value called logfile

  4. Modify the string value and set its data value to the log file location
    For example  c:\doorslog.txt

  5. Create a new string value called loglevel

  6. Modify the string value and set its data value to: 6

  7. Restart the Rational DOORS Database Server

    Note: All users need to be logged out of DOORS before attempting to restart the server



For UNIX and Linux:

Start the DOORS Database Server with the following options:

doorsd -p "port number" -L "log level" -l "path to log file"

Where <port number> is the DOORS Database port number and the path to the log file includes the file name.

For example: doorsd -p 36677 -L 6 -l /usr1/logs/DOORSusers.log

Related information

DOORS client logging
Turn off server logging

Document information

More support for: Rational DOORS
General Information

Software version: 8.2, 8.3, 9.0, 9.1, 9.1.0.2, 9.2, 9.2.0.1, 9.2.0.2, 9.2.0.3, 9.2.0.4, 9.2.0.5, 9.3, 9.3.0.1, 9.3.0.2, 9.3.0.3, 9.3.0.4, 9.3.0.5, 9.3.0.6, 9.3.0.7, 9.4, 9.4.0.1, 9.5

Operating system(s): HP-UX, Linux, Solaris, Windows

Reference #: 1399206

Modified date: 15 April 2013