IBM Support

Datastage clients fail to connect with Internal Error 39202

Troubleshooting


Problem

DataStage Client programs (Designer, Manager, Director) experience a connection failure, and the message displayed to the user is: "Failed to connect to host: xxxx, project: xxxx (Internal Error (39202))"

Cause

This error indicates that a problem on the DataStage engine has caused the server dsapi_slave process to fail, and the connection is lost. There are a number of different possible root causes for this message to be displayed, but the most common cause is file permission problems.

Resolving The Problem

View the contents of the $DSHOME/uvconfig file, and locate the UVTEMP property. This property defines the name of the directory where the server maintains select lists and other internal temporary work files. This should be a fully qualified name of no more than 112 characters.

Ensure that the permission on this directory is set to grant read, write, and execute to all DataStage users.   In the case where UVTEMP is set to default location /tmp, the permission on that directory normally grants public read, write, and execute  (directory mask 777).  

If you set UVTEMP to point to a different directory which will not have public write enabled, then you must ensure that DataStage users have full access to the directory via group permission (for example, set group name of new directory to "dstage" or another group for which all DataStage users are members), and then set directory permission to 775, or even 770.

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSVSEF","label":"IBM InfoSphere DataStage"},"ARM Category":[{"code":"a8m50000000L0t8AAC","label":"DataStage"}],"ARM Case Number":"","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"}],"Version":"11.5.0;11.7.0;11.7.1"}]

Document Information

Modified date:
25 October 2021

UID

swg21397631