IBM Support

Running rgy_backup command does not work without any errors on Windows 2008

Troubleshooting


Problem

Running rgy_backup command does not work without any errors on Microsoft Windows 2008 when using IBM Rational ClearCase.

Symptom

The directory ccase-home-dir\var\rgy\backup on this host is expected to be filled, but it is empty.

Steps to reproduce:

  1. Follow the steps in Defining a Windows computer as a backup registry host.
  2. Run rgy_backup to back up the registry data from the primary registry host to the directory ccase-home-dir\var\rgy\backup, but it is empty.
  3. There is no output in the rgy_backup log.

Cause

Missing the Windows registry key RegBackup due to Windows Registry Virtualization (User Account Control).

For 32 bit OS:
HKEY_LOCAL_MACHINE\SOFTWARE\Atria\ClearCase\CurrentVersion

For 64 bit OS:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Atria\ClearCase\CurrentVersion

Resolving The Problem

Run the rgy_backup command as an Administrator.

Procedure:

  1. Open the ClearCase Control Panel by using Run as Administrator to update the Registry page.

  2. Run rgy_backup to back up the registry data from the primary registry host to the directory ccase-home-dir\var\rgy\backup on this host.

  3. Optional: Run cleartool getlog rgy_backup from the command line to show output in the rgy_backup log.

    Example output:
    Monday, March 25, 2013 2:07:59 AM. host "<< host name >>", pid <number>, user
    "<user name>"
    Registry backup started at yyyy-mm-ddThh:mm:ss
    Registry backup finished at yyyy-mm-ddThh:mm:ss

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"ClearCase Registry","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.1;7.1.1;7.1.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21395395