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Unable to open a plan in the RTC Eclipse Client or Web UI

Troubleshooting


Problem

This technote explains how to resolve an "Error invoking service" in IBM Rational Team Concert that can occur when opening a plan in the RTC Eclipse Client or Web UI.

Symptom

When opening a plan in the RTC Eclipse Client or Web UI, the plan editor's planned items page shows a stack trace instead of the actual planned items. The exception is a script exception. The script exception might carry additional information: "Cannot compare literals of two different enumerations".


Opening the plan in the Web UI leads to a dialog box saying "Error invoking service". The server exception looks like this:


    java.lang.NullPointerException

    at com.ibm.team.apt.internal.service.rest.serialize.EnumerationLiteralSerializable
    .getItemId(EnumerationLiteralSerializable.java:42)

    at com.ibm.team.apt.internal.service.rest.serialize.AbstractWebUISerializable
    .hashCode(AbstractWebUISerializable.java:22)

    at java.util.HashMap.hash(HashMap.java:324)

    at java.util.HashMap.containsKey(HashMap.java:470)

    ...

Cause

The problem is caused by a configuration of the priority enumeration that is not correctly handled by the Agile Planning tools.

There are work items stored in the database that have a priority value assigned that is not listed in the priority enumeration definition anymore.

This is a valid configuration, however, the configuration is not correctly handled by the planning tools.

Environment

The problem is independent of the environment.

Resolving The Problem

Use the following steps to resolve the problem:

Process Configuration

This procedure ensures that new work items have always have a priority value set that is listed in the enumeration definition.

  1. Open the rich client.
  2. Open the project area editor for the project area that contains the plan that cannot be opened.
  3. Switch to tab Process Configuration.
  4. Open the section Project Configuration > Configuration Data > Work Items > Enumerations.
  5. Select priority from the Enumeration drop-down list.
  6. Ensure that the Default Literal value is set to one of the values.

Data Cleanup

These steps find all work items that use an undefined priority value and assign a defined priority value to them.

  1. Open the work item query editor.
  2. Create a new query.
  3. Add a new condition for the priority attribute.
  4. Check all priority values.
  5. Change the operator of the condition to "is not".
  6. Run the query.
  7. The result lists all work items that cause problems when opening the plan.
  8. Select all work items.
  9. Change the priority using the bulk operation. To do so, right-click an item in the priority (P) column and select "Change Priority" from the pop-up menu.




Leverage the Jazz Community

Jazz and Rational Team Concert have an active community that can provide you with additional resources. Browse and contribute to the User forums, contribute to the Team Blog and review the Team wiki.
Refer to technote 1319600 for details and links.


Related Information

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Product Synonym

Rational Team Concert

Document Information

Modified date:
16 June 2018

UID

swg21391241