Troubleshooting
Problem
This technote explains how to resolve an "Error invoking service" in IBM Rational Team Concert that can occur when opening a plan in the RTC Eclipse Client or Web UI.
Symptom
When opening a plan in the RTC Eclipse Client or Web UI, the plan editor's planned items page shows a stack trace instead of the actual planned items. The exception is a script exception. The script exception might carry additional information: "Cannot compare literals of two different enumerations".
Opening the plan in the Web UI leads to a dialog box saying "Error invoking service". The server exception looks like this:
java.lang.NullPointerException
at com.ibm.team.apt.internal.service.rest.serialize.EnumerationLiteralSerializable
.getItemId(EnumerationLiteralSerializable.java:42)
at com.ibm.team.apt.internal.service.rest.serialize.AbstractWebUISerializable
.hashCode(AbstractWebUISerializable.java:22)
at java.util.HashMap.hash(HashMap.java:324)
at java.util.HashMap.containsKey(HashMap.java:470)
...
Cause
The problem is caused by a configuration of the priority enumeration that is not correctly handled by the Agile Planning tools.
There are work items stored in the database that have a priority value assigned that is not listed in the priority enumeration definition anymore.
This is a valid configuration, however, the configuration is not correctly handled by the planning tools.
Environment
The problem is independent of the environment.
Resolving The Problem
Use the following steps to resolve the problem:
Process Configuration
This procedure ensures that new work items have always have a priority value set that is listed in the enumeration definition.
- Open the rich client.
- Open the project area editor for the project area that contains the plan that cannot be opened.
- Switch to tab Process Configuration.
- Open the section Project Configuration > Configuration Data > Work Items > Enumerations.
- Select priority from the Enumeration drop-down list.
- Ensure that the Default Literal value is set to one of the values.
Data Cleanup
These steps find all work items that use an undefined priority value and assign a defined priority value to them.
- Open the work item query editor.
- Create a new query.
- Add a new condition for the priority attribute.
- Check all priority values.
- Change the operator of the condition to "is not".
- Run the query.
- The result lists all work items that cause problems when opening the plan.
- Select all work items.
- Change the priority using the bulk operation. To do so, right-click an item in the priority (P) column and select "Change Priority" from the pop-up menu.
Jazz and Rational Team Concert have an active community that can provide you with additional resources. Browse and contribute to the User forums, contribute to the Team Blog and review the Team wiki. |
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Related Information
Product Synonym
Rational Team Concert
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Document Information
Modified date:
16 June 2018
UID
swg21391241