IBM Support

Update the WebSphere Application Server components in Rational ClearCase and Rational ClearQuest 7.1

Question & Answer


Question

How do you update the IBM WebSphere Application Server components in Rational ClearCase and Rational ClearQuest version 7.1?

Cause

Unlike the version 7.0.x releases of Rational ClearCase and Rational ClearQuest, the Change Management (CM) Server 7.1 ships with full WebSphere Application Server version 6.1.

One of the many advantages of the full version of WebSphere Application Server is that you can apply updates as these become available. For example, WebSphere Application Server updates might improve the overall performance and availability of ClearCase Remote Client (CCRC) and ClearQuest Web 7.1.

Answer

Updating WebSphere Application Server

There are four main steps to updating the WebSphere Application Server software:


  1. Download the WebSphere Application Server software updates.

  2. Stop the ClearCase Remote Client and the ClearQuest Web 7.1 services, which include the CM Server WebSphere Application Server services and the IBM HTTP Server services.

  3. Update WebSphere Application Server.

  4. Restart the ClearCase Remote Client and ClearQuest Web 7.1 services, including the CM Server WebSphere Application Server services and the IBM HTTP Server services.

    Note:
    If you need to update the Rational ClearCase and Rational ClearQuest FixPack after upgrading WebSphere Application Server, you must first roll back the WebSphere Application Server FixPack, then update the Rational ClearCase and Rational ClearQuest FixPack.

    Note: Installing IBM HTTP Server Fixpack 6.1.0.41 and higher might prevent HTTPS from working if you have ClearQuest, ClearCase, ProjectConsole or RequisitePro installed. See this technote: http://www-304.ibm.com/support/docview.wss?uid=swg21578350




Step 1: Download the WebSphere Application Server software updates

Updates to WebSphere Application Server are called fix packs. For CM Server 7.1, you need the latest fix packs for WebSphere Application Server v6.1. The following location contains information about the latest fix packs: Latest fix packs for WebSphere Application Server


You can also use the Maintenance Download Wizard for WebSphere Application Server V6.1 to determine if new fix packs are available.


Use the following guidelines when downloading the WebSphere Application Server software updates:


  • Select the appropriate platform and architecture/chipset for your server.

  • On some system platforms, WebSphere Application Server is available in both 32-bit and 64-bit. Always select the 32-bit fix pack when given a choice because the WebSphere Application Server components in the CM server is a 32 bit application.

  • Update the AppServer (Application Server) component, the IBM HTTP Server component, the WebSphere Plug-ins, and the Java SDK component. These components require separate downloads. Copy the downloaded files to the server you want to upgrade. Make a note of the download location.

    6.1.0-WS-WAS-<platform>-FP00000<fix pack>.pak
    6.1.0-WS-IHS-<platform>-FP00000<fix pack>.pak
    6.1.0-WS-PLG-<platform>-FP00000<fix pack>.pak
    6.1.0-WS-WASSDK-<platform>-FP00000<fix pack>.pak

    On Windows:
    > cd <install directory>\common\IHS_updateinstaller\maintenance

    On UNIX and Linux:
    $ cd <install-directory>/common/IHS_updateinstaller/maintenance

  • The ClearCase and ClearQuest 7.1 Installation Manager installs the Update Installer for WebSphere Application Server V6.1 and V6.0.2.21 (onward). Upgrade the Update Installer for WebSphere Software to the latest v6.1 version.




Step 2: Stop the ClearCase Remote Client and ClearQuest Web 7.1 services

Issue the following commands at the command prompt:


On Windows:
> cd <install-directory>\common\CM\profiles\cmprofile\bin
> stopserver.bat server1
> cd <install-directory>\common\IHS\bin
> apache.exe -w -n
"IBM HTTP Server 6.1 - RationalSDLC" -k stop


On UNIX and Linux:
$ cd <install-directory>/common/CM/bin/
$ cmserver_shutdown




Step 3: Update WebSphere Application Server

The ClearCase and ClearQuest 7.1 Installation Manager installs the IBM Update Installer for WebSphere Software.

Follow the instructions in the topic Installing a fix pack using the graphical user interface in the WebSphere Application Server Information Center.

  1. Navigate to the directory where the IBM Update Installer for WebSphere Software is installed from the command prompt:

    On Windows:
    > cd <install directory>\common\IHS_updateinstaller\

    On UNIX and Linux:
    $ cd <install-directory>/common/IHS_updateinstaller/


  2. Run the Update Installer.

    On Windows:
    > update.bat or update.exe

    On UNIX and Linux:
    $ ./update.sh


  3. Install a WebSphere Application Server fix pack:

    1. Launch the IBM Update Installer for WebSphere Software.
      The Welcome panel is displayed. Click Next.


    2. The installation location of the product is displayed.
      Select the path for the IBM HTTP Server's path. Click Next.

      Windows: <INSTALL DIR>\common\IHS
      UNIX or Linux: <INSTALL DIR>/common/IHS


    3. Select Install maintenance package.
      Click Next.


    4. The maintenance location where packages are located is displayed.
      Select the corresponding path. Click Next.

      Windows: <INSTALL DIR>\common\IHS_updateinstaller\maintenance
      UNIX or Linux: <INSTALL DIR>/common/IHS_updateinstaller/maintenance


    5. A list of maintenance packages available for installation is displayed.
      Select the package you need installed. Click Next.

      6.1.0-WS-IHS-<platform>-FP00000<fix pack>.pak


    6. Confirm the information from the pre-installation confirmation Summary panel.
      Click Next.


    7. The Update Installer displays the Summary panel (this panel reports information about the completed install action taken).
      Click Relaunch to restart the Update Installer.


    8. Launch the IBM Update Installer for WebSphere Software.
      The Welcome panel is displayed. Click Next.


    9. The installation location of the product is displayed.
      Select the path for the IBM WebSphere Application Server. Click Next.

      Windows: <INSTALL DIR>\common\eWAS
      UNIX or Linux: <INSTALL DIR>/common/eWAS


    10. Select Install maintenance package.
      Click Next.


    11. The maintenance location where packages can be found is displayed.
      Select the path. Click Next.

      Windows: <INSTALL DIR>\common\IHS_updateinstaller\maintenance
      UNIX or Linux: <INSTALL DIR>/common/IHS_updateinstaller/maintenance


    12. A list of maintenance packages available for installation is displayed.
      Select the package you need installed. Click Next.

         6.1.0-WS-WAS-<platform>-FP00000<fix pack>.pak
        6.1.0-WS-WASSDK-<platform>-FP00000<fix pack>.pak



    13. Confirm the information from the pre-installation confirmation Summary panel.
      Click Next.


    14. The Update Installer displays the Summary panel.
      Click Relaunch to restart the Update Installer.


  4. Update the WebSphere Plug-in

    On Windows:

    1. Rename the 6.1.0-WS-PLG-WinX32-FP00000<fixpack>.pak file using a .zip extension and extract all the files

    2. Find and copy the mod_was_ap20_http.dll in plg.webserverplugins.FP610<fixpack>.pak\repository\plugins.http\bin.

    3. Rename the existing mod_was_ap20_http.dll in <install-directory>\common\IHS\modules

    Example: mod_was_ap20_http.dll.old

    4. Paste the new file from step #2 into the directory in step #3.


    On UNIX and Linux

    1. Rename the 6.1.0-WS-PLG-<platform>-FP00000<fixpack>.pak file using a .zip extension and extract all the files.

    2. Find and copy the mod_was_ap20_http.so (.sl on HPUX) in plg.webserverplugins.FP610<fixpack>.pak/repository/plugins.http/bin.

    3. Rename the existing mod_was_ap20_http.so (.sl on HPUX) in <install-directory>/common/IHS/modules

    Example: mod_was_ap20_http.so.old

    4.
    Paste the new file from step #2 into the directory in step #3.




Step 4: Restart the ClearCase Remote Client and ClearQuest Web 7.1 services
  1. Issue the following commands at the command prompt:

    On Windows:
    > cd <install-directory>\common\IHS\bin
    > apache.exe -w -n
    "IBM HTTP Server 6.1 - RationalSDLC" -k start
    > cd <install-directory>\common\CM\profiles\cmprofile\bin
    > startserver.bat server1


    On UNIX and Linux:
    $ cd <install-directory>/common/CM/bin/
    $ cmserver_startup



  2. Validate that the ClearCase Remote Sever and ClearQuest Web 7.1 are functioning properly by looking at the log file:
    <install-directory>\common\CM\profiles\cmprofile\logs\server1\SystemOut.log

    The top of the file shows the version of WebSphere Application Server that is running.

    For example, if you updated to Fix Pack 6.1.0.23, the log file will look similar to this:

    ************ Start Display Current Environment ************


    WebSphere Platform 6.1 [BASE 6.1.0.23 cf230910.10]  running with process name ....


    Also, the file <install directory>\common\IHS\logs\error.log.[timestamp] has the version of IBM HTTP Server that is running.

    For example, if you updated to Fix pack 6.1.0.23, the file will contain information similar to this:

    [Tue May 05 12:24:09 2009] [notice] IBM_HTTP_Server/6.1.0.23 Apache/2.0.47 (Win32) configured -- resuming normal operations
    [Tue May 05 12:24:09 2009] [notice] Server built: Dec  4 2008 16:52:28

[{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Web Server (7.1)","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.1;7.1.0.1;7.1.0.2;7.1.1;7.1.1.1;7.1.1.2;7.1.1.3;7.1.1.4;7.1.1.5;7.1.1.6;7.1.2;7.1.2.1;7.1.2.2;7.1.2.3","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"CM Server","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.1","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}},{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"CM Server","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21390803