Troubleshooting
Problem
When trying to open one of supplied DB2 GUI tools the Java splash screen starts to open and then disappears.
Symptom
DB2 GUI tools not opening
Cause
Corrupted *.prf files
Environment
Windows operating systems
Resolving The Problem
Rename the following *.prf files to *.prf.backup and start the GUI tool again.
db2cache.prf
db2dbamr.prf
db2misc.prf
db2tools.prf
The *.prf files are located under:
For DB2 V8.x and 9.1:
- \Program files\IBM\SQLLIB\<instance name>
- On Windows 2008, Windows Vista, Windows 7 and higher:
\PROGRAMDATA\IBM\DB2\<DB2COPY>\<instance name>
NOTE: By default the ProgramData folder is hidden.
All other Windows Versions:
\Documents and Settings\All Users\Application Data\IBM\DB2\<DB2COPY>\<instance name>
NOTE: By default the Application Data folder is hidden.
For further discussion on this topic, visit this developerWorks forum thread:
https://www.ibm.com/developerworks/community/forums/html/topic?id=96c01d88-3c23-4e5b-9b6d-74c3e8663060
[{"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"OTHER - Uncategorised","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.5;9.1;8.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21390434