IBM Support

[ ERROR ] CFG-ERR-0103 Unable to start IBM Cognos 8 service.
Execution of the external process returns an error code value of '-1' after upgrade

Troubleshooting


Problem

The version of the IBM Cognos product has been upgraded (for example upgraded from Controller 8.x to Controller 8.y). When attempting to start the IBM Cognos 8 service by launching 'Cognos Configuration', and pressing the 'start' icon, the services attempts to start, but there is an error message.

Symptom

Successfully launched a test JVM with the memory setting of '1152'. Note that this does not guarantee that IBM Cognos 8 will start and run successfully.

To see which JVM options are based on this setting, view c8_location/bin/bootstrap_<OS>.xml and see your JVM documentation for an explanation of those options.

Since the value is empty, the feature is disabled. There is nothing to test.
11:24:23, 'LogService', 'StartService', 'Success'.
11:24:25, 'ContentManager', 'getActiveContentManager', 'Failure'.
DPR-CMI-4006 Unable to determine the active Content Manager. Will retry periodically.
11:24:25, CM-CFG-5063 A Content Manager configuration error was detected while connecting to the content store. CM-SYS-5003 Content Manager is unable to access the content store. Verify your database connection parameters, and then contact your database administrator for assistance. Failed Logon:com.jnetdirect.jsql.JSQLException: Trusted connection failed. Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'. [OleDB Status:80040e4d], url:jdbc:JSQLConnect://SQLservername:1433/ContentStore_name/trustedAuthentication=true Cause: Failed Logon:com.jnetdirect.jsql.JSQLException: Trusted connection failed. Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'. [OleDB Status:80040e4d], url:jdbc:JSQLConnect://entsql1:1433/Hermes_ContentStore/trustedAuthentication=true Runtime Exception stack trace: com.jnetdirect.jsql.JSQLException: Failed Logon:com.jnetdirect.jsql.JSQLException: Trusted connection failed. Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'. [OleDB Status:80040e4d], url:jdbc:JSQLConnect://SQLSERVER:1433/ContentStore/trustedAuthentication=true at com.jnetdirect.jsql.JSQLDriver.connect(Unknown Source) at java.sql.DriverManager.getConnection(DriverManager.java:562) at java.sql.DriverManager.getConnection(DriverManager.java:208) at com.cognos.cm.dbstore.CMDbStoreFactory.getInitialConnection(CMDbStoreFactory.java:1929) at com.cognos.cm.dbstore.CMDbStoreFactory.initContentIndependentBeforeLock(CMDbStoreFactory.java:2051) at com.cognos.cm.dbstore.CMDbStore.initializeContentIndependentBeforeLock(CMDbStore.java:4586) at com.cognos.cm.server.CMServlet.initializeContentStoreContentIndependentBeforeLock(CMServlet.java:2405) at com.cognos.cm.server.CMServlet.init(CMServlet.java:2130) at com.cognos.cm.server.ContentManager.start(ContentManager.java:301) at com.cognos.cm.server.ContentManagerLifecycleHandler.start(ContentManagerLifecycleHandler.java:63) at com.cognos.pogo.services.DefaultHandlerService.start(DefaultHandlerService.java:101) at com.cognos.pogo.services.DispatcherServices.startInititalServices(DispatcherServices.java:416) at com.cognos.pogo.transport.PogoServlet$PogoStartup.run(PogoServlet.java:681) at java.lang.Thread.run(Thread.java:810)
11:24:26, 'com.cognos.pogo.contentmanager.coordinator.ActiveCMControl', 'pogo', 'Failure'.
DPR-DPR-1035 Dispatcher detected an error.

11:24:56, 'CPS Producer Registration Service', 'StopService', 'Success'.
11:24:56, 'CPS Producer Registration Service', 'StopService', 'Success'.
11:24:56, 'MonitorService', 'StopService', 'Success'.
11:24:56, 'MonitorService', 'StopService', 'Success'.
11:24:56, 'SystemService', 'StopService', 'Success'.
11:24:56, 'SystemService', 'StopService', 'Success'.
11:24:56, 'ReportDataService', 'StopService', 'Success'.
11:24:56, 'ReportDataService', 'StopService', 'Success'.
11:24:56, 'BatchReportService', 'StopService', 'Success'.
11:24:56, 'BatchReportService', 'StopService', 'Success'.
11:24:56, 'com.cognos.pogo.services.DefaultHandlerService', 'pogo', 'Failure'.
DPR-DPR-1035 Dispatcher detected an error.

11:24:56, 'com.cognos.pogo.services.DefaultHandlerService', 'pogo', 'Failure'.
DPR-DPR-1035 Dispatcher detected an error.

11:24:56, 'EventService', 'StopService', 'Success'.
11:24:56, 'EventService', 'StopService', 'Success'.
11:24:56, 'MetadataService', 'StopService', 'Success'.
11:24:56, 'MetadataService', 'StopService', 'Success'.
11:24:56, 'DeliveryService', 'StopService', 'Success'.
11:24:56, 'DeliveryService', 'StopService', 'Success'.
11:24:56, 'JobService', 'StopService', 'Success'.
11:24:56, 'JobService', 'StopService', 'Success'.
11:24:56, 'ReportService', 'StopService', 'Success'.
11:24:56, 'ReportService', 'StopService', 'Success'.
[ ERROR ] An error has occurred within Tomcat. Please check the log file 'C:/Program Files/cognos/c8/logs/tomcat.log'.
11:24:57, 'ContentManagerService', 'StopService', 'Success'.
11:24:57, 'ContentManagerService', 'StopService', 'Success'.
11:24:57, 'LogService', 'StopService', 'Success'.
11:24:57, 'LogService', 'StopService', 'Success'.
[ ERROR ] CFG-ERR-0103 Unable to start IBM Cognos 8 service.
Execution of the external process returns an error code value of '-1'.

Cause

There are many different potential causes for the error 'CFG-ERR-0103 Unable to start IBM Cognos 8 service.
Execution of the external process returns an error code value of '-1'' error. For some more examples, see the related documents section at the end of this Technote or search the IBM Technote knowledgebase.

Notice specifically in the error message the following: 'Failed Logon:com.jnetdirect.jsql.JSQLException: Trusted connection failed'.

In this scenario, inside Cognos Configuration, the setting for 'Data Access - Content Manager - Content Store' has an entry where the 'Type' is set to 'Microsoft SQL Server database (Windows Authentication'. However, the IBM Cognos 8 service is set to logon as the default ('Local System') Windows account. The 'Local System' account does not have rights to access the Content Store database.

Prior to the upgrade, the IBM Cognos 8 Windows service was configured to logon with a Windows user (for example DOMAIN\Controller_service) which had rights to the SQL server to logon to the ContentStore database.

Resolving The Problem

Either:

1) Reconfigure Cognos Configuration so the Content Store's database connection has the Windows username and password specified, or

2) Manually modify the IBM Cognos 8 Windows service to logon with the appropriate Windows user.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.4;8.3;8.2;8.1","Edition":"Not Applicable","Line of Business":{"code":"LOB10","label":"Data and AI"}},{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU053","label":"Cloud \u0026 Data Platform"},"Component":"Install and Config","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.2;8.3;8.4","Edition":"All Editions","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
28 November 2022

UID

swg21389708