IBM Support

"EJB beans could not be deployed, while publishing to the server" error message is thrown during application deployment

Troubleshooting


Problem

Using WebSphere Integration Developer V6.1.2 interim fix 004 with WebSphere Process Server test environment V6.1.2.0, and after upgrading to V6.1.2.3, some applications fail to deploy.

Symptom

The following error message is seen during application deployment using WebSphere Integration Developer V6.1.2 interim fix 004 with WebSphere Process Server test environment V6.1.2.0, and after upgrading to V6.1.2.3:

EJB beans could not be deployed, while publishing to the server.

In addition, some users may experience the same problem, when they are at WebSphere Integration Developer V6.1.2 interim fix 003, WebSphere Process Server test environment V6.1.2.2, and have upgraded their WebSphere Process Server test environment underline JDK to a newer version, such as, SR9.

Cause

There can multiple causes for this error to occur. One of the recently identified causes is related to an incompatibility between the JDK levels used by the workbench, and that of the runtime. Similar problems have already been identified in Rational Application Developer, and tracked as APAR PK85674. The APAR is fixed in V7.0.0.9 release of Rational Application Developer. Users on WebSphere Integration Developer V6.1.2 interim fix 004, which is based on Rational Developer V7.0.0.8, are strongly recommended to move up to Rational Application Developer V7.0.0.10 based WebSphere Integration Developer V6.1.2 interim fix 005, in order to solve this problem.

Resolving The Problem

As a workaround for this problem, follow these steps:

1. Ensure that your WebSphere Process Server JDK is SR9 and up. This verification can be performed as shown, assuming WebSphere Integration Developer is installed on D:\Program Files\IBM\WID61

==
D:\Program Files\IBM\WID61\runtimes\bi_v61\java\bin>java -version
java version "1.5.0"
Java(TM) 2 Runtime Environment, Standard Edition (build pwi32devifx-20090226a (S
R9-0 +IZ44410+IZ44495))
IBM J9 VM (build 2.3, J2RE 1.5.0 IBM J9 2.3 Windows XP x86-32 j9vmwi3223ifx-2009
0225 (JIT enabled)
J9VM - 20090224_30451_lHdSMr
JIT - 20081112_1511ifx1_r8
GC - 200811_07)
JCL - 20081129
==


If your result shows that the current JDK level is higher than the version above, no action is required. Otherwise, you need to upgrade the server JDK by following the instructions in this document:http://www.ibm.com/support/docview.wss?uid=swg24022256

2. If your version of WebSphere Integration Developer is installed in D:\Program Files\IBM\WID61, the shared plug-in repository is located in D:\Program Files\IBM\SDP70Shared. Open D:\Program Files\IBM\WID61\eclipse.ini and change the line similar to:

==
-vm
D: \Program Files \IBM\SDP75\jdk\jre\bin\javaw.exe
==


to point to the newly upgraded runtime JDK:

-vm
D:\Program Files\IBM\WID61\runtimes\bi_v61\java\jre\bin\javaw.exe


Alternatively, you may modify the same line to point to the tooling JDK:

-vm
D:\Program Files\IBM\WID61\jdk\bin\javaw.exe


3. Open D:\Program Files\IBM\WID61/Configuration/config.ini and add the following statements to the end of the file:

==
EJBDEPLOY_SYSTEM_CALL_RMIC=true
==


If the workaround provided above does not solve your problem, you may need to consult product support to resolve the issue.

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Document Information

Modified date:
15 June 2018

UID

swg21388608