IBM Support

Probe using default properties

Technote (troubleshooting)


Problem(Abstract)

Probe is configured with custom properties in the properties file, but is using the incorrect default value.

Symptom

Property RulesFile set to $OMNIHOME/rules/syslog.rules. However, the probe is reading the rules from the wrong directory -

05/20/09 13:35:45: Information: Connecting ...
05/20/09 13:35:45: Debug: Reading /opt/netcool/omnibus/probes/linux2x86/syslog.rules
05/20/09 13:35:45: Error: Failed to open Rules file: /opt/netcool/omnibus/probes/linux2x86/syslog.rules
05/20/09 13:35:45: Information: Falling back to previous rules file.
05/20/09 13:35:45: Error: Failed to read rules: could not open rules file
05/20/09 13:35:45: Error: Failed to initialise session: Opl library error (see previous messages)


Resolving the problem

First, verify the probe is reading the properties correctly by running nco_p_probename -propsfile filename -dumpprops. This will output the probe properties as set in the property file. Verify the output against the properties file setting.

Second, check if the Name property is set in the probe properties file. The Name property determines the names of the properties file, rules file, message log file, and store and forward file. If the Name property is set after other properties, it will overwrite the previous settings. Ensure the Name property is set first in the property file.

Document information

More support for: Tivoli Netcool/OMNIbus

Software version: 7.3.1, 7.4.0, 8.1.0

Operating system(s): AIX, HP-UX, Linux, Solaris, Windows

Software edition: All Editions

Reference #: 1386600

Modified date: 05 March 2015