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Guidelines for troubleshooting TPAE and Maximo domain look up issues

Troubleshooting


Problem

Below is a step by step guide to help find the root cause for domain lookup issues.

Symptom

For example: clicking on the lookup doesn't do or show anything

Cause

Often this is caused by a missing maxlookupmap entry for a particular target attribute

Environment

Any Maximo 6.x or Maximo 7.x environment

Resolving The Problem

For domain lookup issues, a general approach like the following could be helpful (please see also attached screens hots with each step):

1. Turn the sql logging on to track if the lookup query is being executed and whether they look right.
2. Use alt-F1 to determine the actual field that is having the problem.
3. Use database configuration or direct sql query maxattribute to find out the classname and/or domain associate to the field.
4. Check the correctness of the domain and check if the field validation makes sense to be there.
N.B!: The rule is that the domain's list will be used if the domain exists.
If the field validation derives from the same domain name, then the field validation's list will be used. (This normally only happens with synonymdomain)
5. Check maxlookupmap entries for this field as "target='the object' and lookupattr='the attribute'.
Make sure all relevant values are being mapped correctly. The field itself normally would have to be there.
6. If there is no maxlookup map, try it by adding the mapping that you think is correct.
7. If DVL is used as domain type= PSSDVL, try to convert it to a regular maxtable domain to see if the problem is due to DVL.

Explanation on steps with screenshots.doc

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Document Information

Modified date:
17 June 2018

UID

swg21386548