ANR0162W Supplemental database diagnostic information: -1051

Technote (troubleshooting)


Problem(Abstract)

A Tivoli Storage Manager server fails to start or initiate with ANR0172I and ANR0162W errors and SQL error code 1051.

Symptom

An example of error messages follows :


$ /opt/tivoli/tsm/server/bin/dsmserv format dbdir=/tsmdata/tsmdb1 activelogsize=2000 activelogdir=/tsmdata/tsmactlog archlogdir=/tsmdata/tsmarclog
...
ANR7801I Subsystem process ID is 3451.
ANR0900I Processing options file /home/tsminst1/dsmserv.opt.
ANR7814I Using instance directory /home/tsminst1.
ANR4726I The ICC support module has been loaded.
ANR1908W Invalid value for ACTIVELOGSIZE parameter - 2000MB. The default value
2048MB is used for this parameter.
ANR0152I Database manager successfully started.
ANR0152I Database manager successfully started.
ANR0172I rdbdb.c(1044): Error encountered performing action CreateDatabase.
ANR0162W Supplemental database diagnostic information: -1051:**No State
Information Available (89)**:-1051 (**No Other Information Available (69)**).
Failed (sqlca.sqlcode = -1051 ) to create database TSMDB1
Error 2158 initializing the database
ANR2678E Server database format failed.

In the above messages, the SQL error code is 1051

Cause

Incorrect ownership of db and/or log directories

Environment

Tivoli Storage Manager Server 6.1

Diagnosing the problem

When Tivoli Storage Manager Server fails to start or fails to initiate with an SQL error code, the sql code can offer more information on the nature of the error. In this case, the SQL error code is 1051. From the DB2 command line processor, the following command may be used to get more information on the error :


db2=> ? sql1051

It offers the following explanation and user response text.

Explanation

One of the following conditions is true:

  • The value specified for the database directory or storage path does not exist or is inaccessible.
  • Storage paths must have an absolute path name and cannot be relative.
  • An attempt is being made to activate or connect to a database but a storage path cannot be found or it is inaccessible.
  • An attempt is being made to restore an automatic storage database while maintaining the storage paths defined in the backup image. However, a storage path cannot be found or it is inaccessible.
  • A rollforward is attempting to replay a log record related to adding storage paths but a storage path cannot be found or it is inaccessible.

User response

Depending on the condition:

  • Create the path if it does not exist, or change the permissions of the path if it is inaccessible. Resubmit the statement or command.
  • If specifying a relative storage path name then specify its absolute path name instead. Resubmit the statement or command.
  • Resolve the issue with the storage path and resubmit the command. If the storage path is no longer available then the database must be restored from a backup image.
  • Create the storage path if it does not exist, or change the permissions of the path if it is inaccessible. Alternately, the storage paths can be redefined using the ON parameter of the RESTORE DATABASE command.
  • Create the storage path if it does not exist, or change the permissions of the path if it is inaccessible. Alternately, restore the database again and redefine the storage paths associated with the database. When storage paths are redefined during a restore, all subsequent add storage path log records are ignored.

Resolving the problem

In this example, the problem is caused by an incorrect ownership or permission with dbdir, activelogdir and archlogdir. The "ls -al /tsmdata/" command shows directory tsmdb1, tsmactlog and tsmarclog are owned by root user and only root has write access.

The Tivoli Stoage Manager Server Administrator Guide mentions that "for all directories that were created for the server instance, ensure that the user ID that owns the server instance has access. The directories to check include the instance directory and all database and log directories. Change the owner of the directories that were created to the user ID for the server instance.
Following the above example, use the below commands to change ownership of the db and log directories to the instance owner, which belongs to tsmsrvrs group in this case :

cd /tsmdata
chown tsmsrvrs:tsmisnt1 tsmdb1
chown tsmsrvrs:tsmisnt1 tsmactlog
chown tsmsrvrs:tsmisnt1 tsmarclog

Once the ownership has been changed, run the failing command again.


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Document information


More support for:

Tivoli Storage Manager
Server

Software version:

6.1

Operating system(s):

Platform Independent

Reference #:

1386130

Modified date:

2011-04-18

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